My cdrw and my cdr are running in Multi-Word DMA-2 !?

Hi! … recently i changed my cpu & motherboard ( my ‘‘a: drive’’ burned and damaged the mobo and it was still under warranty so it got replaced for 0$) and since then i cant get my cdrom and my cdrw to run in udma2 :frowning:

In Device Manager under the IDE-atapi controller , the hdd is running in UDMA-4 , my lite-on 40125S and my sony cd-rom cdu4821 are running in M-W udma 2 ?!?!

My PC:

-PIII 700Mhz;
-MSI 694-T Pro Bios 5.0 (7.5 coming);
-P/S 250W (350W coming soon);
-Win XP Pro (No SP1 but all update d/l from M$);
-Riva TNT2 Model 64 32mb (AGP)
-SB PCI
-256mb PC133

IDE1:
Primary: HDD ‘Quantum Fireball LCT 1020’ (20G 5400rpm)
IDE2:
Primary: Litey 40125S [fw ZS0P]
Slave: Sony CDU4821 [fw S0P]

anyone can help me ??? thanks for any help

i know that my Lite-On can run in UDMA 2, and i think that my cdrom can run too in udma2 because before the hardware update, the 2 drive were running in udma2. Why are the 2 runnig in MW UDMA 2 ?

The good news is that even though the devices are running in multiword DMA 2, there won’t be any significant performance hit. The 16.7 MB/sec capacity of this mode is more than enough for the fastest burner, and it is operating in a true DMA mode which should allow maximum performance potential.

The bad news is that obviously UDMA 2 is better, primarily because it requires a little less CPU utilization than DMA 2. The extra speed of 33 MB/sec is not really required, as it is only used for extremely brief cache memory bursts.

WinXP sometimes spontaneously resets ATAPI devices like burners from DMA mode to PIO mode. When this happens, performance suffers significantly. It is possible that this has happend with your system, and it was fortunately reset to DMA 2 instead of PIO.

This resetting of connection modes is a bug in WinXP with no real solution as yet. If this is what caused your problem there is a workaround that will fix it until it happens again:

Go to Device Manager and remove the IDE channel to which the devices are connected and reboot. On system startup, the IDE channel and devices will be redetected and UDMA hopefully may be enabled. Check in Device Manger to confirm that UDMA is enabled.

thanks for your reply :wink:
… but i have a question : In Device Manager i go to ‘‘dvd/cdrom’’ or ‘‘ide ata/atapi controllers’’ and then what do i do ? i disable it or unistall it ? yesterday, i try to unistall it and get a simultaneous reboot and death screen a boot up :frowning: damnit :confused: can you help me then ? :rolleyes:

The IDE channel which had the device(s) should have been removed (uninstalled), not the CD-ROM and burner. It should be redetected on startup.

If you removed the channel on which your hard drive is located, it may not be finding your boot drive.

Try starting the system in Safe Mode and enable the IDE controller.

thanks alot for your help … but like i said in my previous post, i try, yesterday, to unistall it (secondary IDE channel) and i got a simultaneous reboot and at the (next) boot up, i got a blue screen of death telling me that it rebooted to not let me unistall it (or something like that i dont rememver exactly) so what could be the problem !!! i am really confused right now :confused: :rolleyes:

Can you still open the operating system and use the computer?

I got the same problem too!! my CD writer should run at DMA 33 yet it juz run at PIO…

Originally posted by Inertia
Can you still open the operating system and use the computer?

yes , i can still use it ( im on it right now and since then …) at the second(?) boot up, win xp ask me how to start it : normally (didnt work; blue screen & reboot) and ‘as before’ or something like that and i selected it and it run good but my secondary ide channel is running again in mw dma 2 :confused:

If you remove the secondary IDE channel in Device Manager and reboot, it should be detected and reinstalled on rebooting. It should not cause a blue screen error. This has been many times in these forums with successful results.

If this is what you have already done and it caused a problem, then something else must be causing it. If you can’t follow this procedure successfully, then just leave the devices connected at DMA multiword mode 2. They should still reach maximum performance.

Originally posted by Inertia

If this is what you have already done and it caused a problem, then something else must be causing it. If you can’t follow this procedure successfully, then just leave the devices connected at DMA multiword mode 2. They should still reach maximum performance.

its what i try … thanks anyway for helping me :stuck_out_tongue:

:bow:

Don’t give up yet, there is still one more chance to fix the connection speed. :slight_smile:

I believe that your motherboard has a VIA chipset. Confirm this and go to VIA 4in1 Drivers. Download and install these latest drivers and reboot.

Many times the installation of these latest IDE drivers will fix any problems and allow the highest UDMA connections. :wink:

i have already try that yesterday and didnt work , i installed(?) the via 4in1 4.43 (i think?) … by the way, is there a way to know if the via drivers are installed corectly because i dont see any where in my pc where it say if they are installed …?!?

If you open the registry by running regedit, the key at HKEY_LOCAL_MACHINE\Software\Via4in1Driver will indicate which version of the 4in1 drivers are loaded.

got 3 files there:

default value not set
4in1Version 4.42
Viamach 1.70

ok then ! its installed correctly right ?!!

Yes.

First, there’s no much speed improvement for your CD-ROM/CD-RWs running higher than UDMA2. UDMA2 already providing 33MB/s transfer rate and should be enough for almost all CD-ROMs.

Second, if one of your device can’t run higher than UDMA2 and you connected with the same cable, then the whole IDE Channel can’t run modes higher than UDMA2.
e.g: Device A support up to UDMA4, and Device B support up to UDMA2 and you connect them with the same cable to an IDE Channel, then that channel can’t run higher than UDMA2.

Third, Via 4in1, aka Hyperion 4in1 driver, is no use for IDE devices running above UDMA2/3. The best driver is to download IDE miniport driver 3.014. It provide full UDMA6 support under Win2000/XP(with latest service pack).

Originally posted by Richteralan
First, there’s no much speed improvement for your CD-ROM/CD-RWs running higher than UDMA2. UDMA2 already providing 33MB/s transfer rate and should be enough for almost all CD-ROMs.

If you read this thread again, you will see that although black~cobra is using the term M-W UDMA Mode, the thread tile uses the correct description of Multi-Word DMA-2. I took his meaning as M-W DMA mode 2, as the multiword description is usually dropped when describing true UDMA modes. M-W DMA mode 2 has a transfer rate of 16.6 MB/sec.

Second, if one of your device can’t run higher than UDMA2 and you connected with the same cable, then the whole IDE Channel can’t run modes higher than UDMA2.
e.g: Device A support up to UDMA4, and Device B support up to UDMA2 and you connect them with the same cable to an IDE Channel, then that channel can’t run higher than UDMA2.

This is incorrect, and hasn’t applied for years except to old hardware. Modern IDE controllers have independent device timing which allows each device to operate at its rated connection mode.

Third, Via 4in1, aka Hyperion 4in1 driver, is no use for IDE devices running above UDMA2/3. The best driver is to download IDE miniport driver 3.014. It provide full UDMA6 support under Win2000/XP(with latest service pack).

He is not using the Hyperion 4in1 driver, but v4.42. The IDE miniport driver version 3.014 was released over a year ago. Why is the the best for WinXP?

BTW, the person to which you suggested this driver in another thread had to remove it as it would not let CD Speed and DVD Speed run. :cool:

If i open my case and un-plug the IDE2 cable from the mobo, then boot , work on it (win Xp would(?) see that there no drive on ide2) and shut it down : plug in back the IDE2 cable , start it, would the pc redetect the drive by itself , or stay in mw dma2 ?? could that help ??

thanks…

       Marc

It’s worth a try. Microsoft recommends swapping with another drive to force redetection.

The Microsoft Knowledgebase article at Programming of Transfer Mode Speed Is Not Supported by Atapi.sys When You Hot or Warm Swap Drives does not match up with your problem, but it gives insight as to why swapping drives or removing the IDE controller works to restore UDMA modes.