My CD-RW wont read or burn disc's

Hello, I am having trouble with my CD-r:

I have a Cd writer, a liteOn 52327s. About 2~3 months ago my burner began giving me trouble. It would burn slower that usual, and eventually it stopped reading/writing to CD’s. The odd thing is, i was about to give up until i tried it on a different computer and it worked. Im out of ideas of what it could other than some DRM software, or a virus. I was wondering if anyone had any other ideas other than the ones i tried so far.

  1. I tried many different types of CD’s/CDR’s discs, and none worked.

  2. I tried switching the Jumpers and re-arranging the configuration on my IDE cable, Both times the CD-r doesn’t work, the DVD reader does.

  3. I updated the firmware.

  4. I uninstalled/reinstalled the Cd-r through the device manager.

  5. I tried the CDr in a different computer and it worked, I put it back in mine it still doesn’t read discs. (this is the part that pissed me off)

My system specs are.

Pentium 4 2.8GHZ (HT)
Nvidia 5900 Fx (128Mb)
1 gig of kingston ram (4x256 sticks)
An MSI 865PE Neo
liteOn 52327s Cd/r
and a sony dvd rom ddu1621

try replacing your drive cable.