My Benq dw-1655 is RPC-1 without any firmware update!?

vbimport

#1

I have a Benq dw-1655 OEM. After I first installed it I started searching for a RPC-1 firmware but when I ran Nero Infotool, It shows that it’s already RPC-1. I uninstalled DVD Region Killer to see if maybe that was causing a false report but it still reports as RPC-1. I’ve tryed all my Region 2 and Region 3 DVDs and they all work. Is there any idea why thats the case?


#2

whats it say when you look at the drive in device manager?


#3

It sez Benq DVD LS DW1655 SCSI CdRom Device

(it sez scsi but it’s IDE)


#4

Is it a new or used drive?


#5

New, I got it from Newegg.com


#6

What version of firmware did it come with? Can you post the Nero InfoTool screenshot?


#7


#8

I thought OEM drives came with a different series of firmware. The B series of firmware is usually reserved for the retail drives IIRC. And RPC1… Strange! One of the experts here can probably throw more light on this. Anyhoo, is it working well? Tried some burns yet?


#9

Either there is already a (se-)regioning software running in the background or someone has maybe flashed this drive before, RMA’d it and you bought it then…


#10

I deffinately ordered an oem drive. I don’t have anything running in the background. The only thing I can think is that maybe it was flashed and then returned or something.