My Awful Experience with Plextor (PX-712A)

vbimport

#1

I would like to write this as a warning to people who are planning on buying the PX-712A or other Plextor Products.

I purchased my PX-712A last August after reading many favorable reviews about how fast, reliable, and quiet it was. When I received my PX-712A it worked fine for the most part, except it would refuse to burn DVDs faster than 2.4x without huge buffer problems. I was fine with this and thought it may have been my computer that was causing the problems. Then 2 months ago it would start freezing and crashing my computer whenever I put a CD or DVD in it.

I RMA’ed it to Plextor and received a replacement last week, which was kind of slow but at least they sent me a new one no questions asked. The problem is, this drive is also dysfunctional and will freeze Windows Explorer if I try running any kind of CD or DVD in it. :a

Now I understand that sometimes you get bad eggs off the assembly line, even with the best brand drives, but I simply find it unacceptable that Plextor made me pay for shipping to return their broken product only to send me another broken one. I wrote them an email expressing my disatisfaction with their product quality and customer service, and I told them that I want them to pay for shipping both ways this time because I refuse to pay to ship back the broken product they sent me. I have been without a functioning optical drive for over a month now and it is very annoying.

I will update on what their reply is…


#2

Welcome to the forum! Thanks for sharing your experience with us.

Then 2 months ago it would start freezing and crashing my computer whenever I put a CD or DVD in it.
Sounds like a problem that I see many times in this forum. Do you want us to try troubelshooting and isolate your problem?


#3

Sorry I’ve already returned that drive and I’m stuck with this broken one. Both of them have the same problems in other computers I’ve put them in. Thanks for the offer though.


#4

Slightly offtopic, but does 712 support DVD+R DL reading or not? Firmware has “supported” it from 1.03 (using 1.07), but I’m confused as not a single program (Plextools, Nero etc.) reports that capability.


#5

puffarthur, to be honest I think the problem is not related to the Plextor drive and most likely a system related problem. When the buffer is bouncing around it indicates that your system cannot supply the drive with data fast enough (because of a too slow system, DMA problem, driver problem, etc.). The fact that the replacement drive does the same thing makes me conclude that your system is indeed the culprit. You say you have tried the drive in another computer as well but this doesn’t tell us much. Please post your system details here so we can take a look. Also, it would be helpful if you could run the drive’s self-diagnostics test and perhaps try the drive in a completely different computer (with different hardware specs). How are your jumpers set-up on the back of the drive? It’s recommended to run the drive as MASTER as a SINGLE device on the IDE channel (to rule out any problems, usually the drive works fine when another device is attached to the same IDE channel).

@ jaska915: it does.


#6

Slightly offtopic, but does 712 support DVD+R DL reading or not? Firmware has “supported” it from 1.03 (using 1.07), but I’m confused as not a single program (Plextools, Nero etc.) reports that capability.
There is no way to tell that a drive can’t read DVD+R DL.

Programs like Nero InfoTool can report that
a) the drive definitely can read DVD+R DL
b) the drive might be able to read it or not

If a program really says “drive cannot read DVD+R DL”, then its author has a bug to fix…

Plextor has quite a bunch of firmware b0rks in DL reading, for example the PX-712 cannot read the booktype of a DVD+R DL, cannot read the manufacturer ID of a DVD-R DL, and even the PX-716 cannot read the DVD writer used to record a DVD-R DL (or, if it does, it is not working the way it is supposed to work).


#7

UPDATE: Plextor refuses to pay for my shipping, so I am refusing to do business with them ever again. I hate their shoddily made products and their unfriendly customer service. I recommend you do the same if you want to save yourselves the headache.

G@M3FR3@K:

For some reason I doubt it is my system. My specs are:

Athlon 64 3000+ cpu
1GB Kingston RAM
XFX NVidia 6600GT
ASUS K8N-E Mobo
Western Digital 80GB 7200rpm HDD on SATA
Western Digital 250GB and 180GB 7200rpm HDD on PATA
Plextor PX-712A as Master on its own PATA

Even if it is my system and not the drive’s fault that it burns slowly, that wasn’t the problem. The problem was that suddenly the drive just stopped working and froze my computer completely whenever I tried to put any form of disc in it. Got the same results when trying it in another computer. I RMA’
ed it and received another drive that basically refuses to acknowledge that any disc is in it, or simply freezes windows explorer. I am very pissed because I paid for shipping to return the 1st defunct drive only to receive another defunct drive, and they expect me to pay to ship back their crap AGAIN.


#8

Try this from Plextor FAQ:

Q: When I insert a DVD disc in my Plextor drive my computer restarts or gives me a blue error screen!
A: When you have installed Sonic DLA it will cause problems with your Plextor PX-708A or PX-712A drive. Please uninstall this software or disable it. (Reports of these problems can be found here and here.) Update: The following software applications can also cause blue screens: Creative Playcenter and Real Player. For more information read this thread.


#9

When you insert a recorded CD/DVD into the drive and then Explorer crashes, it is almost always a software conflict. Try turning off all the auto-launch features of your various CD/DVD programs (Nero, Roxio, Sonic DLA, Alcohol, Plextools, Winamp, WinDVD, PowerDVD etc etc etc). Especially when an identical problem rears up on a different drive.

If the drive passes the self-diagnostic, it’s almost certainly to do with installed software and not to do with whatever hardware gizmos you’ve got. Just a guess, but that’s probably what’s behind Plextor’s refusal to pay shipping


#10

First would should do a system restore that my fix it if this started to happen after you installed any programs. Another problem it could be is that your power supply cant handle the load that your putting on it.


#11

Thanks for the suggestion, guys. I do not have Sonic DLA, Creative Playcenter, Real Player installed. I turned off all the auto-launch features of Nero, Winamp, and WinDVD and still the same problem. I don’t believe software is the issue, because even when I put the CD or DVD in the drive, I go to My Computer and it simply shows that the drive is empty. When I try to double click on it to run, it freezes Windows Explorer. And it cannot be my power supply because I have a very steady 430W Seasonic PSU. Anyway, I already ordered an NEC ND-3540A, hopefully that drive is more reliable. Thanks again for all the suggestions.


#12

Be sure to let us know if the NEC does work puffarthur. I still think the problem is software related, especially since you have Sonic DLA installed which is known to cause problems. Anyway, good luck.


#13

puffarthur> as I can see you are running an Athlon based system on NFORCE board.
NForce IDE drivers are known to give problems with Optical drives (I myself had problems with Plextor and Nforce drivers). Please try to uninstall Nforce IDE drivers and use the Microsoft ones bundled with Windows. If you are using Nforce drivers you also could have problems with NEC drives…


#14

Not only with optical drives… those drivers sometimes cause bugs only supposed to exist on VIA chipsets (like that data is modified while being transfered)


#15

alexnoe> yes I can remember there was such an problem with those drivers…
The thing i learned: never use NForce IDE drivers!!!


#16

Oh good call, Koba, thanks. I will definitely report back about my NEC drive once it comes on Thursday.


#17

I hate to ask, but what sound card are you using? There has been much debate over this issue on several brand named MOBOs (Ausu, Abit, Intel…and others). The Audigy 2 causes many brands of optical drives to freeze on read, especially those with realitivly new SATA drives/ports.

I have experienced these problems on my Asus P4P800E-Deluxe with the Intel i865PE south bridge and my Abit IC7-G MaxII with the Intel i875 south bridge. I even returned 3 DVD drives for replacement before I finally got it fixed!

Unfortunately, there has been no good/ lasting fix for the problem. Most companies are ignoring it. Creative sure uisn’t talking, but what else is new? If you think this might be the cause of your problem, you should reaad the following string:

http://forum.abit-usa.com/showthread.php?s=&threadid=11529 

.
I hope this has been helpful. I’m interested to see if any of you do have an Audigy 2 and are experiencing these issues.


#18

i’ve got an Audigy 2ZS Platinum in one of my rigs…just not the one with my 716s…

that being said, i’ve experienced no issues with 4 other ODDs hooked up to the rig with the Audigy in it…(plx premium, 708UF via USB2, Samsung ROM and OLD oem philips cd-r/rw)…


#19

I’m glad to hear that! Just thought it might be something that could have caused those issues…A little more info thrown in the pot.

I hope you get it cleared up soon.


#20

i didn’t mean to debunk your troubleshooting theory at all…the more info the better IMHO…

i also hope you get things sorted sooner than later…