My 3520A slowed up :(

vbimport

#1

It was working great before, its not old at all. It was doing everything right. Then i didn’t rip/burn a dvd in like a week. Yesterday i went to rip a dvd and it wouldn’t read it faster than 1.5x (dual layer dvd, or single layer dvd). I tried 4 dvd’s. Then i tried to burn a cdr, it wouldn’t burn faster than 11.5x on 52x media. Couple weeks ago it was working great.

I’m on Ultra DMA Mode 5 for my IDE primary settings.
I just don’t get it, i didn’t mess with the firmware or anything, but before i could rip/read dvd’s ALOT faster than 1.5x

any help? thx


#2

Did you update the drivers for the motherboard? To be exact the IDE drivers ? Also check the DMA status.


#3

I checked the dma settings “I’m on Ultra DMA Mode 5 for my IDE primary settings.”
No, I didn’t update the drivers for my motherboard, well i installed the drivers that came with the motherboard when i bought it in march.
the Primary ide driver says = "Microsoft, driver date: 7/1/2001, driver version: 5.1.2600.0


#4

Yes but what about the IDE channel that you have the drive on. Nec 3520 supports max Ultra DMA mode 2… so the mode 5 applies to the hard drive I guess.


#5

so what do you suggest I do?


#6

Could you use the Nero Infotool and post the results?


#7

Here are nero info tool screen shots

hmm this says dma is off for the burner?




#8

Yes looks so.


#9

[off-topic]
@Quikee,

Screaming Avatar :cool:
[/off-topic]


#10

Yes… I’m going berserk because Nec doesn’t want to release the PI/PIF firmware for 3500. =) hehe


#11

I was more thinking of this new avatar:

Sorry for this off-topic post :bow:


#12

Ok guys I think i’m back in business

I switched the two ide cables on the motherboard so now the burner is on primary and the hd is on the secondary, and when I did that both have DMA enabled.

Now…would you guys suggest that I apply the hacked firmware to the drive and try to increase speeds? Or leave it how it is…not to sure what the hacked firm ware does…some kinda riplock on my drive I read about?

It seems that I can only read real dvd’s at a 5.0x speed…which sux
But…when i want to read a burned dvd, it will read well over 16x-18x+
So i just don’t get why it won’t read real dvd’s past 5.0x but burned dvd’s real fast

I looked at this site under modified firmware
http://www.micheldeboer.nl/firmware/3520.html

Alot of those have riplock removed in it, which should I choose? I just tested burning and it works great, like its supposted to, now the only problem is read ing disks at 5.0x. Now I read that riplock removed will get rid of this? If so…which firmware should I choose?



#13

The NEC 3520A reads dual layer DVDs at 3-7x max only (avg 5x) even with riplock removed firmware - it can read single layer DVDs and recordable DVDs at 6-16x speed max with riplock removed however. I use a separate Aopen DVD-ROM drive to rip dual layer DVDs at a faster speed 5-12x or 6-16x.


#14

So your saying I should stick with what I got? seeing that its ripping dual layer disks at 5x and recoradable dvd’s at 16x