My 1670 says it's not a valid win 32 application

vbimport

#1

Hi folks!

I’ve just bought a Benq 1670.

I run Win XPSP2 Pro. The drive is on it’s own IEDE channel. The jumper is set to master.

I’m pretty certain it was working ok for a while, though I ran no tests on it. The first indication I got that something was amiss was Nero 7 refusing to start up. I uninstalled that, but now it won’t read the Nero install disk. The drive is intermittent in its ability to read other disks - it won’t read any disks I’ve burned at all. It starts to read, then eventually throws up an I/O error message. I’ve tried everything I can think of, but XP’s Device Manager tells me it’s working ok, I’ve checked the DMA settings are enabled, I’ve run every virus check I can think of, Sandra reports no errors, and I’ve updated the firmware to 1.03.

Now if I put a disk in the PC it’s telling me that the drive isn’t a valid win 32 application, and meanwhile the whole system is running slow…

Yet the device manager tells me it’s working ok… :frowning:

Before I send it back, does anyone have any ideas?


#2

Sounds like something is corrupting the data that is read from the disc.

1st thing I may suggest is to try and boot from a bootable CD (either XP install disc but dont install it or a Linux CD). This will tell you if the problems is windows related or drive related. If the CD boots without error then its going to be a driver in windows thats messed up. If it fails to boot, check the IDE cable for marks or other problems, also try the drive in another PC if possible. If all else fails you may be looking at getting the drive replaced.

BTW, Device manager wont report problems with the device if the interface is still talking, windows device manager can only really detect driver problems that stop windows talking to the device (red X or yellow ?) or total device failure (no power or physically unplugged).


#3

Thanks. Excellent suggestions.

I just tried re-booting from another bootable XP partition (don’t know why I didn’t think to try that earlier!) and the problem persists, so it must be hardware somewhere. I’ll pick up a linux boot CD tomorrow and try that - though that wouldn’t neccesarily isolate the problem.

I’m trying to avoid moving the drive to another PC, which would tell me if it’s the drive itself, or cable/PC.