My 1620 wont read discs recorded by standalone anymore

vbimport

#1

i’m currently transferring my vhs movies to dvd with my standalone dvd recorder. i’m recording in dvd-video mode, and finalizing the discs.

i was then taking the discs to my PC and extracting them to mpegs which i would then edit. this was working just fine yesterday, and it stopped working all of a sudden. when i put a disc in the drive it changes and try to view its contents it says “Windows cannot read from this disc. This disc might be corrupted, or it could be using a format that is not compatible with Windows.”.
the disc reads just fine in another PC with a DVD-ROM drive and it also reads in 3 different dvd players

i tried a different type of dvd-rw disc, did a clean installation of windows xp w/ sp2 slipstreamed, & tried downgrading the firmware from B7T9 to B7P9.

i’m able to erase dvd-rw’s, write to dvd-rw’s & read the written dvd-rw’s… i just cannot read discs recorded by the standalone.

it’s weird because it was working, and then it just stopped… everything else is working fine with the drive…

has anyone else experienced this or have any suggestions?


#2

by the way, i tried moved this drive to another PC. same results.


#3

well??

bump


#4

Go to a friend and try the disc in another dvd rom drive. If the benq can’t read it I don’t know what else to do. Or buy a dvd rom drive to read your recorded discs.


#5

already tried that, it reads on every other device (dvd-rom’s, dvd players), but it just wont read on the benq… i dont feel i should have to purchase another device because the benq doesnt do something its supposed to… gonna call up benq and check out getting a replacement.