My 1620 pro stopped working but

vbimport

#1

I dont understand this.
WHen i Power on computer, the drive dosent led up… I cant eject it at all. No responds. If I fire up a dvd program, I can see the 1620 device, but if i try eject it with software nothing happends. There is a disc in drive, my burning programs report the drive as not ready… So, the drive dont read the disc, the led is not working, i cant eject it, but the computer find the drive …

So i tried to flash the drive in this condition, and guess what, THAT worked.
During flashing the led was flashing again. I rebooted, still cant use eject button, still no led when booting, still not working.

What can be wrong???

I tried change power cables too, but didnt work.
No more benq, this is second 1620 that fucks up for me. Horrible!


#2

EsspeN, I had almost the EXACT same problem a few months back on my old DW1620. See this thread…and my conclusion was that it was a heat problem. Not sure where you live, but due to the weather getting warmer now, it might be related…


#3

i also had the same problem. i sent the drive back to my seller for an exchange and the new one is working fine, for now.

-andy-


#4

another one bytes the dust :frowning:


#5

No more BENQ for me… Looks like quality control is real bad on these drives.


#6

Anyone care to guess whether December 2004 would be affected to? Indeed any of yous have ones from that batch??


#7

And my Drawer wont stay closed .
I just installed it for the First Time.
(10 Time’s Today) SHUT THE DAMN DRAWER !!!
I am not comfortable Flashing . But
If Someone Know’s a Better way too
Get My LED Up When I Boot ? (()//////D~
Beep,Buzz,Page,Fax Me .