Multiword DMA with 3500

vbimport

#1

I am having problems getting my new 3500 to burn at speeds above ~8x. My second IDE channel refuses to run at anything above Multiword mode 2. I tried messing with my VIA bus master ide controller driver and ended up having to reinstall windows after the updated drivers refused to let me use the drive at all. Also, I tried using VIA’s IDEtool to change to UDMA33, but after restart, I was right back to Multiword mode 2. I have been able to find other instances of people with this problem, but nobody seems to have a good answer about how to fix it.

System:
Athlon Thunderbird 1.33 Socket A
Gigabyte GA-7DX with AMD 760 Northbridge and VIA 686B Southbridge
512 MB PC2100
Windows XP Pro with every update except SP2
Primary IDE Channel: Master:Maxtor 160GB at UDMA mode 5
Slave: WD 200GB at UDMA mode 5
Secondary IDE: Master: NEC 3500 running at Multiword mode 2
Slave: Pioneer 106 running at Multiword mode 2

Does anyone have any ideas?


#2

Go to Device Manager and remove the secondary IDE channel. Reboot into BIOS. Verify that the optical drives are set to AUTO with DMA enabled. Reboot PC and windows will reload the driver. Confirm DMA mode 2 with the NEC in device manager.


#3

If worse comes to worse swap your Primary IDE and Secondary IDE channels. Using a KT133A chipset I had to do that to force my optical drives into Ultra DMA Mode 5… nothing other than that would kick them off of Multiword DMA 2… And you wonder why I went Intel on the next computer? :slight_smile:


#4

had the same problem… but i used a silicon image cmd 649 ide card…on that card i have only multiword 2 with the nec on the controller on the mainboard udma2 so i have to change my cabels to have udma 2…
so you could try to buy a ide controller card and look if the nec have there udma 2…:wink:


#5

Might want to install ms ide drivers instead,as to the kt133a thats a crappy via problem,nothing to do with amd.


#6

Well I messed around some more, and finally wrote a DVD at 16x. The only way that the drive is recognized as UDMA mode 2 is when it is attached on the primary IDE channel. right now I have it set as the slave to my boot drive on the primary IDE channel. The secondary channel now has my pioneer DVD drive and my second hard drive. The second hard drive runs in UDMA mode 5, but the second DVD drive still won’t go above Multiword DMA mode 2. Does anyone see any major problems running the 3500 as a slave on the same channel as my boot drive?


#7

No, just make sure that when burning with the nec the image is on your second hard drive, so source and destination are on seperate channels.


#8

Try tu put the jumpers not on CSEL, but use MASTER and SLAVE. Use AUTO detection of the drives in BIOS.