MultiWord DMA 2 insted of UDAM 2

vbimport

#1

Hello there...

maybe there is someone out there who knows this better than me..

i bought an Acer 2010A Cd-RW not so long ago, and my litle question is that in WinXP i can´t get i to run any higher than Multi Word DMA 2, i have looked at acer´s homepage and can´t fint anything about it´s max DMA transfer rate. But shall not almost every new Cd-rw run at UDMA 2. ? ? , does any of you have this Acer model and som more experience than me ?

maybe i´m completly wrong...

// Deputy_1


#2

The writer could be detected wrong.
In that case remove it (and all other ide devices and drivers !) from the hardware properties and let windows re-detect it.

also if your mobo has a via chipset , make sure to get the latest via drivers at www.viatech.com (4 in 1 drivers i thought).

last :

DMA Mode 2 at 16.6 MB/s
Ultra ATA/33 at 33.3 MB/s
Ultra ATA/66 at 66.6 MB/s

Multi-word DMA Mode 1 13.3 MB/s
Multi-word DMA Mode 2 16.6 MB/s
Ultra ATA Mode 2 33.3 MB/s
Ultra ATA Mode 4 66.6 MB/s

the fastest writers only write at ((40x150k)/1024) = 6 megs per second.


#3

If you have an Epox 8kha+ … like me … the you need to get a BIOS upgrade for your MB.

The new BIOS will contain an option to enable UDMA support for CDROM drives.Which isn’t enabled by default.

Before upgrading my BIOS I couldn’t get my DVD or CD-RW to run in UDMA mode 2 either.

However … this was a while ago… shortly after the 8KHA+ was available.

But make sure you are using the latest BIOS for your MB and the latest firmware for your Burner.

And make sure to check your BIOS for an option to enable UDMA on CDROM drives.

EDIT : typo


#4

I tried all kinds of thing yesterday, but no luck … i have the latest bios version for my Abit Kt7a, and have the UDMA option in bios set to Auto, i also tried this i found at another forum… but no joy there …

Open RegEdit

Find the following KEY

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class{4D36E96A-E325-11CE-BFC1-08002BE10318}\000x

The last four digits will be 0000, 0001, 0002, 0003, and so on.

Under each key, delete all occurences of the following values:

MasterIdDataChecksum

SlaveIdDataChecksum.

Reboot the computer. Windows will now redetect DMA settings.


#5

Ok next thing to check is the IDE cable … is it 80 pins … designed for UDMA 66 etc.


#6

yepp it´s a 80 pin cabel i have, so i´m begining to think my Cd-rw is to be operated in MW DMA 2…


#7

You might try deleting the ide controller from device manager and then re-starting. It might take more than one delete/restartg cycle. Worked for me on an Abit KT7 RAID.

Originally posted by Deputy_1
yepp it´s a 80 pin cabel i have, so i´m begining to think my Cd-rw is to be operated in MW DMA 2…


#8

This Acer is a UDMA device like the 1610A (I have one). Multiword DMA is no good because it’s simply PIO Mode in disguise (well, very PIO Mode ‘like’ more words but still…), so it will hog the CPU. While it will never reach UDMA/ATA33 speeds, it’s the mode of running (bypassing CPU), busmastering etc that’s important.

You can manually change the setting - search for a post by PaRaDoX in the CloneCD Forum (I’m on an NT4 box ATM so I can’t step you thorugh the process - maybe later if you can’t find the thread)


#9

Thanks rmunde And FutureProofe

I think i found the thred by PaRaDoX (if it´s the reeeealy long one), im rather sure that i can get my Cd-Rw to run faster than MW DMA 2 but than i have to install the VIA IDE miniport driver 3.14, and that is someting i have been adviced NOT to do (at viaharware forums). but i got some new things to try now so thanks !

// Deputy_1


#10

I keep an eye on VIA Arena, like PaRaDoX does, and all VIA chipset drivers are now safe, since 4.33 anyway :wink:


#11

Ahhhh now i don´t know aything

just recived an e-mail from ben-q (old Acer)…

"Dear Sir,

UltraDMA is not supported in the cdrewriter. DMA/2 MW is the maximum.

With Kind Regards,

BenQ Support"

I just saw a guy in another forum saying his ACER 1832A (10x8x32), (older than mine) works with UDMA … strange

hehe… i´l think im begining to give up :confused:


#12

My 1610A is definately UDMA33:

enumerates as such in the POST (ATA33)
DMA enabled in Device manager (off MoBo channel)
and, shows as UDMA Mode 2 off my PCI ATA100 Card


#13

Weren’t there some burners out there that needed a jumper to be set on the rear of the drive in order to enable UDMA?


#14

hi !

yes I´v heard the samt thing but i dont have one on mine burner, just the regular jumpers …