Movie with two tracks in audio

Have a avi file that plays in vlc but has two tracks. When I enable track 2 it plays in english which is what I want. However if I put it on my tv it plays with the english and another voice in another language over it. I want to make a new avi with just the english. Is there a way this can be done. I have dvdx and movavi. The english is the main language in film which is on track 2 and the male voice is translating on track one but when playing on tv get the two tracks. Can I just make a new avi with just the track 2 version and please how? New at this so would appreciate any help. If played in media player it only plays with the two tracks also.
Thanks for any help.
hairygeorge

Try AviDemux, import/open the avi…In 'Audio, tab choose whatever audio track you want, and exclude the one you don’t want…Make sure you set both Video and Audio to 'Copy" so as to, [I]not[/I] re-encode…Save a new AVI, making sure you include the the [B].avi[/B] extension…
http://www.videohelp.com/tools/AviDemux

I’d use virtualdubmod; it’s a lot faster than AviDemux for this:

  • load avi into virtualdubmod
  • under the video menu choose direct stream copy
  • under the stream menu choose stream list
  • select the audio stream that you want to remove and click disable
  • now choose file->save as… to save the result

Slainte

midders

[QUOTE=t0nee1;2444648]Try AviDemux, import/open the avi…In 'Audio, tab choose whatever audio track you want, and exclude the one you don’t want…Make sure you set both Video and Audio to 'Copy" so as to, [I]not[/I] re-encode…Save a new AVI, making sure you include the the [B].avi[/B] extension…
http://www.videohelp.com/tools/AviDemux[/QUOTE]

I downloaded this but can’t work out what audio to choose. Could you please help.
regards

If you successfully loaded the avi in Avidemux with two audio tracks, click on ‘Audio’ tab->Main Track–>Audio source: set to’ Video’…Track from Video: choose either track 0 or track 1, from the dropdown menu…