Most stubborn DMA>PIO mode problem ever, looking for help please

My burner is stuck in PIO mode. I have been unable to reset to get DMA working using the normal methods. Looking for help and suggestions.

In my registry, under HKLM/hardware/devicemap/scsi/scsi port 1, the DMAEnabled value resets to 0 whenever the computer attempts to detect new hardware or changes. I believe this is why the drive reverts to PIO even though my transfer mode is set to “DMA if available”.

After hours of experimentation, here’s some of what I have tried so far:

resetdma.vbs script
manually changing DMAEnabled to 1 in registry (always resets to zero)
uninstalling/reinstalling IDE controller driver
using alternate IDE controller driver
manually deleting the checksum in the registry
adding “ResetErrorCountersOnSuccess”=1 to registry
removing and reinstalling the drive after doing above steps
physically replacing the drive (lite-on) with a different drive (hp)

no results. I am trying to avoid re-installation of windows at all costs. Any suggestions?

edit: I am using windows XP w/ SP2 and all latest patches. My bios does not allow control over drives (dell laptop). I also can not try replacing cables as there are none. DVDFab’s magic “DMA Reset” button did not work either.

Welcome to the forum :slight_smile:

You have a Dell, so you might want to try this, if you haven’t already.

Good luck! :slight_smile:

Thanks for the help and quick reply. I just tried that program. It produces a unique result:

The program instantly changes my secondary IDE controller to display that it is in UDMA-2. It also reverts the hard drive from UDMA-5 to UDMA-2, and sets all my slave devices (which do not exist) to UDMA-2. However, all the symptoms of being in PIO are still there, and upon rebooting the properties sheet shows PIO again. My problem listed earlier with DMA being disabled in the registry persists as well. Even if I manually turn DMAEnabled=1 in the registry, then run dell’s program, the machine is still in pio. DMAEnabled resets to zero upon reboot.

Any other ideas?

That’s very strange, I’m as stumped as you are now. :eek:

I’ll re-read your original post and see if there’s anything else I can dig up.

[I]lucidchaos[/I], put a disc in drive and run Nero CD/DVD Speed Transfer rate and burst test. Guide.
Post us the figures. :wink:

In my registry, under HKLM/hardware/devicemap/scsi/scsi port 1, the DMAEnabled value resets to 0
On my (Intel chipset) lappy this value is always 0x00000000.
Still all drives run in full DMA mode. :smiley:

After about 15 mins of testing, the speed has been a consistant 1.23x reading a dvd. My cpu usage is at 100%. I am running it as we speak, and the computer can not keep up with my typing as it is working so hard. This is after running Dell’s utility and with windows reporting all drives in UDMA-2.

My lappy is using a intel 915GM chipset. The other laptops I have with intel chipsets all show DMAEnabled=1 in the registry. Is your drive slaved off the first ide channel or is it on the second set as master?

Do you have Intel chipset drivers installed? Linky.

Don’t think our lappys have much in common, no sata support here.



I tried switching between the driver I had and the windows built in IDE controller with no luck. I also tried updating the intel drivers, as well as installing a slightly different variation of intel driver (915G instead of 915GM) with no result.

I am starting to think the problem is most certainly something resetting my Scsi Port 1 DMAEnabled to 0, after seeing your config. It makes sense that your dma would be disabled on secondary IDE since you have nothing hooked up to it.

BTW thank you both for being so helpful and taking the time.

No problem :slight_smile:

Usually incases like this, where nothing else has worked, I would advise to change the IDE cable (I know that’s not what you wanted to hear). Either that or bite the bullet and reinstall the OS.

It seems every other option has been tried. :frowning:

I’m doing a winxp repair install as i write this. I’ll post back with the results.

Finished with the repair install.

The DMA gremlin is in there real good.

DMAEnabled is still resetting to zero upon reboot / hardware detection.

I will most likely end up reinstalling clean in a few days, I’ll wait it out for suggestions / backups / sanity purposes :slight_smile:

Is it possible the optical drive mating connector inside the laptop is damaged in some way? Some kinds of damage might lead the controller to automatically back down to PIO mode and then it might actually work OK in that mode.

Also, have you double checked the Event Viewer to see if there are notations in the logs about the IDE channel being reset to PIO?

-brendan

http://winhlp.com/node/10

try this link, it will change it for you