MKVs are unplayable

vbimport

#1

When I choose to convert DVDs to mkvs using the generic conversion tool, the resulting mkvs are always unplayable. Zoomplayer throws up an error saying that no such codec exists.

However, exporting to MP4’s and then remuxing them to MKVs using MKVmergeGUI gives me perfectly playable MKVs every time. I’d like to not have to go through this extra step each time if possible. Let me know if you need any more information. I’ll be happy to provide it, if it helps to fix the problem.


#2

There are 4 or 5 generic profiles that make MKVs–which one are you using? I tried two (H.264+AAC and AUDIOCOPY) which played perfectly with VLC media player.


#3

This is an old bug that has never been properly fixed. Please see this initial thread. I am also doing a remux to make the MKVs work. VLC will play them but is more resiliant to errors in files then for instance Tvix and Popcorn players that has problems.

http://club.cdfreaks.com/f116/dvdfab-platinum-gold-hd-decrypter-option-mobile-5-0-7-5-out-249573/#post2101384


#4

It’s nice to know I’m not the only one paddy. I can’t even remux my bad MKV’s though. MKVmergeGUI says fails every time I try. How have you been able to remux yours?


#5

The developers will still need to know which profile and settings you are using.


#6

Sorry signals, I too am using the H.264+AAC profile.


#7

[QUOTE=brihanrohan;2147787]It’s nice to know I’m not the only one paddy. I can’t even remux my bad MKV’s though. MKVmergeGUI says fails every time I try. How have you been able to remux yours?[/QUOTE]

TSMuxer will help you demux it to its elemental streams. Then I use the MKV gui to remux them.


#8

[QUOTE=brihanrohan;2147787]It’s nice to know I’m not the only one paddy. I can’t even remux my bad MKV’s though. MKVmergeGUI says fails every time I try. How have you been able to remux yours?[/QUOTE]

I’ve also tried the (H.264+AAC and AUDIOCOPY profiles and they worked for me…

In the meantime try by using tsMuxer to first extract (demux) the video and audio streams> then using mkvmerge Gui, import H.264+ audio file to create a new MKV…Hope it helps…

EDIT: looks like Paddy97 posted, while I was sloowly typing…:cool:


#9

[QUOTE=signals;2147909]The developers will still need to know which profile and settings you are using.[/QUOTE]

I’m using Generic.mkv.h264.audiocopy.

The picture quality is outstanding. Just a pity that the muxing is not 100% up to par.


#10

With VLC the play position slider jumps around some but the playback is flawless. Hopefully Ting can fix this.


#11

I used tsmuxer to demux the dvdfab generated mkv, and then mkvmergeGUI to mux it back to a mkv again.

No matter what FPS I set the video stream at, and even checking/unchecking “AAC is SBR…” for the audio stream, the video and audio always play out of sync in the remuxed mkv.


#12

If the original file is 29.970 fps ,then that’s what you type in as FPS in MKVMerge Gui…
Don’t use the drop down menu,unless the original is 24,25,30,etc.etc.

Is the dvdfab generated mkv in sync?


#13

[quote=t0nee1;2148584]etc.

Is the dvdfab generated mkv in sync?[/quote]The ones I made as tests have perfect A/V sync when played on VLC.


#14

Same here, signals… :iagree:


#15

I would suggest you use AVI instead of MKV when generating files in DVDFab until the issues with MKV are fixed. There is no real advantage in MKV format in DVDFab at present since none of the extra features of MKV are being used (e.g. chapters, selectable subtitles, mutiple sound tracks, etc.).

Just my $0.02.