.mkv Help!

vbimport

#1

Okay, i have tmpgenc and i try to open the .mkv file and it gives me an error message saying it can only open the audio files.

so i get angry and jump up and down and click over to virtualdubmod, where i load the .mkv… after it’s done parsing it says i have “An out-of-bounds memory access (access violation) occurred in module ‘ntdll’” and it shuts down.

So i get angry and jump up and down and repeat my proceedure over and over again.

I have the latest matroska pack installed, but nothing is working for me, i’ve tried riverpast video cleaner as well, but quality sux and i get no audio.

Need lots of help…

Thanx addison


#2

The few matroska files I’ve had have all loaded into VirtualDUBMod with no problems. Sounds like a problem mkv file, but sorry, I have no idea how to fix it.


#3

Yeah I got the same error when trying to load a .mkv file. I downloaded the file with 2 audio dubs attached and i want to remove one of the audio files. Everyone said to use Virtualdubmod, but it won’t load the matroska files. Are there any other possible programs i can use to remove one of the audio files from the mkv. files.


#4

http://www.bunkus.org/videotools/mkvtoolnix/
VirtualDubMod’s Matroska library is very old.
//Danne


#5

VirtualdubMod cant even handle 30% of the MKV files out there. Thats sad, but true. Dont forget, VirtualdubMod is based on Virtualdub, which by itself is based on the old, outdated VfW ( Video for Windows ) framework from M$.

matroska, on the other hand, is a modern container allowing all the things that are impossible with VfW, like VFR video ( Variable Framerate ) and VBR audio ( Variable Bitrate ).

Things got very complicated once Gabest had implemented RV9 ( Realvideo ) muxing into MKV, as RV9 is VFR by default, so there was no way to make a RV9 VCM codec for use in VirtualdubMod, and Cyrius soon noticed that it didnt really make sense to try to expand VirtualdubMod to read MKV files any longer.

mkvtoolnix and avi-mux GUI are the right tools to handle MKV files today … and maybe TCME in future :wink:


#6

Hi I got a problem mkv file.

Video plays in VLC. Audio is not playing properly. But only audio plays in avisynth. No video at all.

I uninstalled all codecs and installed matrosa pack 1.03. Gspot is not able to identify the fourcc but it can render the file. The results are ffdshow MP4 and corevorbis audio. Previously with all the other codecs installed i got the result as XVID 4. I also tried the avi2vcd decompressor.exe. and got a xvid video and pcm audio muxed in an avi. but no luck processing it with vdubmod(it parses and then says corrupt data) and tmpeg.

Can any1 help or suggest a place where i can get help. i have not tried the mkvtools yet. should I?

Do I need to recompress at all? Can i just play it just the right codec?
Can i burn the file in CD as data?

Thanks a lot.


#7

Get mkvmerge from http://mkvmerge.matroska.org ( dont forget the runtimes ), fire up the GUI mmg.exe, load the MKV and remux it into a new MKV …


#8

mkvmerge v0.9.5 (‘The Na Na Song’) built on Aug 21 2004 17:46:01
Tried your suggestion and t his is what I got:
FAILED with a return code -1

‘C:\xxxxx.mkv’: Using the Matroska demultiplexer.
‘C:\xxxx.mkv’ track 1: Using the video output module.
‘C:\xxxx.mkv’ track 2: Using the Vorbis output module.
‘C:\xxxx.mkv’ track 3: Using the text subtitle output module.
The file ‘C:\xxxx.mkv’ has been opened for writing.


#9

Please try this version of mkvtoolnix : http://www.bunkus.org/videotools/mkvtoolnix/win32/pre/mkvtoolnix-0.9.5-build20040927-1.rar

Mosu made it especially for your case :slight_smile:


#10

Thanks.It remuxed. However the problem has not been solved. I was able to stream the video to an avi with VLC. And it played without any problem. But audio (raw dumped to wav) is not playing properly. And now the AVS wont play at all. Hangs up the system. Problem is with the audio stream.