Missing or corrupt file in Win2k

vbimport

#1

Recently I get error message stating “ntoskrnl.exe file is missing or corrupt. Please re-install a copy of this file” when Win2k is trying to start. I tried copying the file from 1 PC to another, but the problem persists. How can this file be re-installed?


#2

Check your start up programs (Spybot has a utility to check start ups). You may have something you don’t need that’s trying to load. Or try some kind of safe-mode or boot-time virus scan. Maybe you have a trojan or virus. I recently solved a problem by doing a boot-time scan (avast! freeware antivirus program scan found the problem). regards, gamma1…


#3

How can startup programs be checked before Windows is started? Same error message is given if boot to Safe Mode is attempted.


#4

I’m out of ideas other than trying a boot-time virus scan. I assume you can boot up to start the scan, right? It took over an hour on my computer and found several trojans…:confused: good luck, g1


#5

It’s dual boot Win2k and Win98SE, and Win98SE boots with no problem. Could a boot time virus affect boot of 1 OS and not the other, and how is a boot-time virus scan done?


#6

[QUOTE=bevills1;2054905]It’s dual boot Win2k and Win98SE, and Win98SE boots with no problem. Could a boot time virus affect boot of 1 OS and not the other, and how is a boot-time virus scan done?[/QUOTE]

Not an expert here, but I think it could affect only one system. I use avast antivirus home edition with WINXP, which is freeware and the home web site says it will work with WIN98. With avast, you “schedule” a boot-time scan, then reboot. It finds trojans and viruses and you can put them in a “Vault.”

You probably have a different antivirus program installed. If you can only boot to WIN98, Open your antivirus program (whatever one it may be ) and see how you can set up boot-time, Safe Mode or other full system scan and see what happens…

I hope some of the more knowledgeable Freaks can contribute some ideas here.
:eek::rolleyes:


#7

There seems to be much more wrong than just a missing or corrupt file. Booting to Win2k install CD and selecting repair via Console it goes directly to Console without asking which Windows I want to logon. Once there I’m unable to type “cd directory name” to change directory or execute any Console commands on the drive where Win2k is installed, and I get “Access is denied” when any of those tasks are attempted. I figured this out by trying the exact same steps on a similar system that’s working normally, and it prompted for Windows to logon, “cd directory name” to change directory and execute commands in the Console with no problem. I’ve no idea what’s going on, but it appears may be time for a new install.


#8

This is from a thread I started at another Forum.

I just thought I would relay an advantage this non tech rookie in training found tonight. I tried to boot into my XP64 side tonight and received the following error: blah, blah, the following file is either missing or corrupt: Windows Root\sytem32/ntoskrnl.exe. So I of course booted into my XP32 side & googled the error, quite a few links came up, mostly about using the disc & accessing the recovery console. I didn’t want to get into anything complicated before going to bed, because you know what happens, you start & it ends up being about 3 or 4 AM before you are done. Thought about it for a while because this sh1t bugs me & I can’t let it go. As I could still access my XP64 Drive from XP32, I right clicked on the drive, Properties, Tools, Error Checking & clicked Check Now. With the Check Disc options, I probably could have got away with just checking the box (Automatically Fix File System Errors), but I also checked the box (Scan For And Attempt Recovery Of Bad Sectors). Pack a lunch because it takes a while, but after completion I restarted & booted into my XP64 side with no problem at all, in fact that is where I am posting this thread from. Old news to some, but new to me.


#9

4X2gigs


#10

I also ran “chkdsk /R” from the Console, and it indicated 1 or more errors were found and fixed when it completed, but my problems in post #7 persists after that. Do you think it would do any good to boot to Win98SE and run Win98SE scandisk on the Win2k drive?


#11

http://support.microsoft.com/default.aspx?scid=kb;en-us;Q292175


#12

No Win2k install is found when repair option is selected, and I guess it’s time for new install. What’s perplexing about it is that all directories are seen when the Console is chosen to repair, and all files and folders are seen when booted to Win98SE too. I suppose there’s some missing or corrupt files that makes the Win2k invisible only to Win2k Setup and to boot files.


#13

make sure W2k is installed on a seperate partition and you are using sp4 with all the security rollups before connecting to the internet


#14

Thanks for the advice. I have Win2k slipstreamed SP4 CD, and I don’t think it’s even possible to install Win2k on same partition as Win98 without over writing the Win98 install; I’ve always installed Win2k on separate partition.