Missing format on seagate hard drive

vbimport

#1

Hi, have a Seagate 3tb hard drive. 2 partitions and formatted under MBR. all of sudden, the partitions lost its formatting. cannot retreive my files at all. direct plug into m/b does not show the hard drive. during boot-up,bios show the hard drive having smart issues. however, when I insert this hard drive in my Vantec external hard drive dock, it shows up with only one partition showing and Win 7 Pro 64 bit telling to format the partition over and over again. this action prevent me from ever trying to use my file recovery software (GetDataBack) to see if my files are recoverable. Is it hopeless to recover the files.


#2

So, is sector 0 maybe damaged on the hdd at all?!
That should be checked first, then you could try to recoiver the data from the disc, maybe even with testdisk.


#3

not sure if it is damaged, but I do get smart problem raised during bios boot-up when I attached the drive directly to my m/b. After I reached my decktop, my computer does not show the drive at all. however, if I connected the hard drive via external hard drive dock, I can get Win to recognized the drive. Once Win recognized it, it keep telling to format the partition. should I go ahead and format the partition again,and use the file recovery program to recover all my files. I don’t know if this is pertinent,but all this occurred when my bios switch the boot sequence, normally, the first boot device would be my hard drive containing the O/S, however somehow, bios switch to this problem hard drive as the first boot device. Once, I noticed what was happening, I set the boot device back to the proper place.


#4

How old is the mobo and its firmware?


#5

MBR formatting on a 3TB drive is problematic and will not be supported by some devices, like the dock that only sees the first partition. Windows trying to format the drive when connected to that dock might be related to the dock’s inability to handle it.
Have you tried booting Windows to safe mode? In Windows, with the drive connected to MB, does it show up in disc management?


#6

I know about the 2TB limitations of MBR. The problem is Windows is not recognizing the hard drive. I’ve tried using the Testdisk partition recovery program to see if it will see the partition and nothing. Would installing a new MBR help recover the files? I think my MBR was somehow deleted or corrupted when my computer accidently use this hard drive a boot drive containing my O/S. I only use the external dock because when the drive is connected to my m/b, bios and Windows does not see the hard drive. It behave as if it is new hard drive without any partitions and formatting.


#7

m/b is 3.5 yrs old and it has the latest bios. Asus Formula 3 ROG m/b.


#8

Which Seagate model is it?

Do any programs tell you that the drive has 3 TB of space available to format?


#9

With most USB devices, Windows refuses to recognize anything other than the first patition. See if you can recognize both partitions when booting from a live GNU/Linux distro. If said distro works, you should consider using another USB adapter.


#10

It is Seagate ST3000DM001 7200RPM 3TB hard drive. I have use a few of these same drive divided into 2 partition using MBR. It works fine because Seagate Discwizard will automatically initialized both partitions to work under Window. I have also using the same hard drive partition under GPT. The full 3TB space is utilized once extended allocation in Discwizard is enabled and formatted by Windows. I only using MBR allocation table because of compatibilty with Win XP Pro 32 bit machine I frequently have to use to exchange files .


#11

Did you ever check to see if your drive has a firmware update? If so, did you update the firmware?

I would take TSJ’s advice to see if both partitions are recognized in Linux.