Memorex Twelve Maxx is it screwed?


ive been a silly boy

i have a memorex twelve maxx firmware version lsxa, or should i say had. i recently found out its made by lite-on so i flashed it in dos to version 17 then in windows to version 23, at this point it still worked as a reader but would only burn in clone when set to 1x, because otherwise it would give me power calibration errors. so i decided to try the traxdata 32x10x12 plus firmware, again same shit. so in a final attempt to get a working drive i flashed it with tdk cyclone 32x10x12 version 1.08, it didnt like this probably something to do with the firmware being 512k instead of 256k. anyway is there any utilities for reflashing it and are there any links to memorex version lsxa or better firmware, and what the hell is this drives lite-on model number? i do have another identical drive which i can access for downloading firmware from if this helps. also is it possible to overclock this drive?

ok ive tried reflashing the drive set to master on my secondary ide port of a msi 5169 motherboard. all that happens is the program seems to hang, also there is no activity from the drive either at power up, during post or when i try and reflash. is this drive totally screwed?

I have same Memorex MAXX 1032.
but I do the same error : flash to LTR-12101b firmware.

the burner can only read.

I’m looking for LSXA firmware too.