Memorex Twelve Maxx 1032

vbimport

#1

I recently formated a friends hard drive only to discover that after reinstalling windows me her 12 maxx 1032 was only being detected as a CD-Rom not CD-RW. After checking on the Memorex US website (the UK site and technical help staff are as helpfull as a chocolate tea pot) I discovered that the software that came with the drive corrects this problem. The problem being that my friend no longer has this disk. I have noticed from the various posts on here that the 12 Maxx 1032 may actually be a Lite-on Drive and they mention firmware updates. My questions are as a complete novice at this are

1/ how do i find out what firmware the drive has now

2/ Will updating the firmware get Win ME to detect this drive as a CD-RW

3/ STUPID question I now but how do I update firmware.

4/ or has some kind soul got the original software for this drive that is available for download.

I know that this subject has probably been done to death and I probably sound a complete moron but im at my wits end and my friend isnt too happy with me too.


#2

Windows ME does not detect what kind of drive it is. As far as I know, only Windows XP does this.

In Windows ME you can check your current firmware version on the Settings tab of the drive’s properties in Device Manager.

This is not a firmware problem and I do not recommend trying to flash the drive wil Lite-ON firmware since it wont fix anything. You need to get Nero Burning ROM or another CD burning software in order to use the drive.


#3

I may not have explained myself fully because windows only detects the drive as a CD-Rom not CD-RW neither Nero or Easy CD (tried versions 4.05 and 5) will write to the cds and direct cd says no supported drives are attached also Memorexes own website, the USA FAQ, says this is a known problem and that the software that comes with the drive is required to correct this but as i said earlier my friend no longer has this disk.


#4

The TwelveMAXX 1032 should be supported by ECDC 4.05 and higher. What does ECDC do when you load it? If you go to Tools -> CD Drive Properties in ECDC, does it say that the TwelveMAXX is a CD Recorder or that it’s only a reader?

Also, what version of Nero are you using? If the version of Nero you have tried came with a CD-RW drive other than the TwelveMAXX, it may not recognize the TwelveMAXX as a CD-RW. Try downloading the demo at www.nero.com (uninstall the existing Nero first).


#5

It says its only a reader ill give nero a try but i dont hold out much hope as memorex says u need to install specific software to overcome this problem. And a word of advice to anyone considering buying a Memorex drive DON`T their aftersales service is crap and their tech support staff give morons a bad name.


#6

Did even ECDC5 say it was only a reader? That’s strange. What IDE drivers do you have installed?


#7

The ones that WinME installs


#8

Did you try Nero 5.5.10.28 Demo yet? Also, what version of ECDC5 were you using?

Another question: What ID string is the computer showing for this drive?