Media Player Classic plays FLAC files but

vbimport

#1

How do I tell Media Player Classic that FLAC files are media files so the FLAC files appear in the Open File dialog box?

Note 1. Media Player Classic does play the FLAC files – if I force the Open File dialog box to show “all files.” But the default is to show only “All Media Files” and I can’t get Media Player Classic to recognize FLAC files as media files in the Open File dialog box.

Note 2. If I double click a FLAC file in Windows Explorer, the file plays automatically in Media Player Classic. FLAC files under Windows Explorer show the Media Player Classic icon.

I’m running the latest version of Media Player Classic version 6.4.9.1.

I’m also running the latest K-LITE Codec Pack Full version, which includes the FLAC decoder.

My system is Windows XP SP2


#2

Here’s the solution: Launch Media Player Classic.

Under View > Options > Player, verify that “Store settings to .ini file” is checked.

Then, under View > Options > Player > Formats:

Select “Other.” Enter “.flac” to the list of formats. Click “Set” and “Apply.”

Done.