Maxtor Hd

vbimport

#1

Hi
I just installed a Maxtor 320G hard drive and the BIOS reads only 32 G. I tried flashing with the latest BIOS update, fdisk, and Maxblast . All read 32G. Is it my mother board or just a bad HD.


#2

Hi

Which motherboard do u have?

NBK


#3

You might need to use a PCI card for a drive that size on an older motherboard.


#4

I know this is true of Seagate, not sure about Maxtor, as I haven’t had one since a 20 gig drive - but is there a jumper on the back of the drive that limits the size?

As I say, there was one on my Seagate 120 gig drive, I remember it well 'cos I set the jumpers wrong :o

I’d say CDan’s probably right though, depends on your mobo.

The jumper thing probably isn’t the issue, but it’s worth checking :wink:


#5

As others have said, it’s more likely your motherboard’s BIOS. Award BIOSes with a build date prior to mid-October 1999 have a hard 32GB (actually, 33.8GB) limit in hard drive support. And your motherboard most likely was manufactured before that date - and the latest BIOS for it most likely also had a build date prior to October 1999.

In addition, your motherboard does not support the new 48-bit LBA addressing. So, even if your BIOS is newer than October 1999, you won’t be able to use a hard drive larger than 137GB without having to get a separate add-in PCI IDE controller.


#6

What operating system do you use and is it the drive you use to boot with?
You might not need anything at all…
//Danne


#7

Thanks for the input
I have a chinese generic mobo (I know, you get what you pay for) with SiS 741 chipset, outside the bios chip label mfg date is 1999 but bios flash program dates 10/13/05,figures?My Os- XP version: 5.1.2600 with service pack 2.and Linspire 4.5 -LINUX.


#8

Try this…
Go into BIOS and set HDD detection to None for your “new” HDD.
Remember to have at least SP1 installed in Windows and the newest IDE drivers from SiS.
http://www.48bitlba.com/enablebiglbatool.htm also be sure to enable LBA 48-bit.
After rebooting you should be able to see the whole drive in Disk Management.
//Danne