Maxell DVD-R 4x media = no disc?

vbimport

#1

I bought a 20 pack of Maxell DVD-R 4x discs from Staples Business Depot in Canada. They have a blue surface and a yellow top. They say “Made in Japan” on the back, if that helps.

I tried 5 or 6 from the pack and I get the same result when trying to burn with Nero. It says “insert a blank disc into the drive” and ejects the disc. This was using a BenQ DW1620. I also put one in my Lite-On DVD-ROM drive to see if it would recognize it, but it also didn’t see a disc in there.

I got the 20 pack for $18 so I guess you get what you pay for.

Anyone else have problems with them?


#2

Never had an inklin’ of a problem after about 300 burns…some of the best media ever produced…can’t quite say the same for the 8x Maxell MIJ’s…but they’re still good.

I’ve never actually seen 20 packs Maxell MIJ’s before…10 jewel, 25 spindle…are they narrow jewel cases?


#3

I’m not sure. I just bought the BenQ drive today. Is there a way to check the firmware version?

However,I just updated the Lite-On drive to the latest firmware.

I guess the DVD-ROM drive didn’t recognize it because it didn’t have any data on it yet.


#4

The stock firmware version should be on the label on the drive, it should starts with either G79 for OEM and B79 for retail. Maxell MIJ are one of the best media out there, you might either get maxell made or ty made for MIJ media. I guess you need to update your firmware


#5

I just returned the Maxells and got Verbatims. I got DVD-R and DVD+R.

The DVD-R still weren’t recognized. The DVD+R works fine. I’m assuming it is a defective drive now. I read in another thread that someone had a very similar problem with their BenQ drive. I’m going to return it and get a replacement. Hopefully the replacement will be fine.

Thanks for all the help anyway!


#6

I exchanged the drive for a new one at Future Shop. It recognized the Verbatim DVD-Rs but it still wouldn’t burn to them. I upgraded the firmware to B7V9 and tried it again. Success!