Matshita UJDA755y speed problem

Hi - I have a wierd problem here. My work laptop and my home laptop are virtually identical - both IBM T41’s, both with XP Pro with SP2 and both with identical Matshita/Panasonic UJDA755y DVD-ROM/CDRW combo drives.

The drives both work very well with the home machine - with a data CD, they will read at the rated x24.

However, put either of them in the work machine and they won’t read at any higher than x4.

There was a problem with the DMA controller on the work machine which I seem to have fixed by downloading a driver from the Lenovo website. DMA is enabled on the secondary IDE channel too.

I’ve copied the newwer versions of MSCDEXNT.EXE and ATAPI.SYS from the home machine and I’ve even updated the firmware on the Matshita form 1.72 to 1.74, the latest I can find.

All of these operations have been followed by a reboot but the updated drive in the work laptop will still only read at x4.

Can anyone help me to make this drive perform to spec please?

Thank you!

DMA problem still there, or a cable problem.

[QUOTE=chef;2114494]DMA problem still there, or a cable problem.[/QUOTE]

Chef - thanks for your help. I did already remove the upper and lower filters just as described and I did, I promise you, search the site as I always do on forums like this one.

Yesterday I sussed it. After trashing the registry on my work laptop trying to fix this, I rebuilt it from absolute zero. Still had the same problem, and found something strange with different versions of Nero’s InfoTool. Version is the only one I have found that actually reports this drive’s rated maximum read speed of x24 - other versions report x4.

By accident I was looking in the Power Options to correct something else and I noticed in Advanced Settings, you can set the CD-ROM for “high performance”, “normal” or “silent”. Mine, of course, was set to “silent”. Set to “normal” and the problem’s solved. Checked the home laptop and, yes, that’s set to “normal”.

Why they would default to different settings during ground-up builds (I’ve done 'em both) I don’t know but there you are…

Thanks again