MakeMKV 1.10.12 released, fixes bugs in Ultra HD Blu-ray disc dump feature


#1

Originally published at: https://www.myce.com/news/makemkv-1-10-12-released-fixes-bugs-ultra-hd-blu-ray-disc-dump-feature-83637/

The developer of MakeMKV released an update for his software today. Version 1.10.12 fixes bugs related to the software’s hashed keys function that allows MakeMKV to rip all available Ultra HD Blu-ray discs. Due to the bugs, dumps of several discs were not correct and therefore MakeMKV supports less discs than actually possible.


#2

Is anybody else still having problems with MakeMKV. Installed version 1.10.12 and keys_hashed.txt.
This is the error message I get with all disks which used to work perfectly.


#3

I would assume that title isn’t supported yet. Did you submit a dump on x.12?


#4

No, I have not but it seems MakeMKV is not reading the latest hash_key.txt file. I have tried five disks that I have previously made backups of. None of them are working. I uninstalled then reinstalled MakeMKV + the key file with zero luck. Bummed…


#5

Maybe it only thought it worked before


#6

I still have the first backups I did weeks back. They are still working with MPC, VLC and PowerDVD 17. Now PowerDVD is FUBAR with the latest AnyDVD. It makes backups but they are all, “stream” folders. Makes me question PowerDVD. This week has not started out very well for me. :wink: Think I’ll go back to bed…


#7

You have to put keys_hashed.txt in the MakeMKV Data directory (which can be changed from the Preferences Menu). Data directory is where AACS 2.0 dumps are saved. If you put your hashed txt file there, you’ll be able to decrypt your UHDs again. :wink:


#8

Exactly the problem. Seems earlier versions I installed the file in the c:\program flies (x86)\MakeMKV directory which worked. Now the default directory is c:\users\xxx.mkv.
Thank you all for your help!


#9

So strange that even worked in the first place as it was always intended to go in the user/data directory. I wonder if that was related to the bugs he ironed out in the new version. Either way, good call @TwinParadox. I forgot that was even a possibility or I would have mentioned it…


#10

Good question. Now it’s time to figure out what’s up with PowerDVD. When I use AnyDVD to decode, the directory shows up as a, “stream.” So weird… PowerDVD recognizes my older rips just fine. Well, I’m retired and have a little extra time do this crazy crap. :wink: