Magnavox DVR630R

vbimport

#1

I have a Magnavox DVR630R and it won’t read discs it recorded earlier (some months, some a year or two). I think that at least some of them are discs that were not finalized. It thinks there is nothing on the disc. I have tried everything I can think of and then some. Does anyone have any suggestions? I have even tried Decrypter to Close but that doesn’t work. Some time ago (6 - 9 months) I installed a firmware upgrade. It may have changed something so I cannot read discs that were recorded prior to that. I just don’t know. I have gone through many of my discs and 1/2 to 2/3 don’t work. A lot of money and time invested that I hope is not lost.

Please help if you can.

Thanks.

Authorof22…


#2

Not familiar with your magnavox, but I know that on my JVC, if I fogot to finalize a disk, I was still able to put it back in and finalize it later. And with my JVC, you have to be hooked up to a television and have a remote to go through the menu screens to finalize a dvd. Suggest you read up in your manual (if you have not done so), and see what it says.


#3

I have tried everything. I used to be able to put them back in to finalize, but now that doesn’t work. The machine does not recognize the disk. It says it is empty. What I need to know is if there is some program that I can use to finialize the discs so I don’t end up with over 100 coasters.

Thanks.


#4

Tried Nero? I haven’t run into this problem on DVD media yet, but I could always depend on it to close my CD media.


#5

It is also possible that the media that you used has degraded, and you may need to find someone with a higher quality dvd reader in order to attempt to copy them to a hard drive and reburn them. What is the media id for your dvd’s?