Mad Dog 16x Dvd firmware flashing

vbimport

#1

Hello everyone I am new to this forum and need some help please… I bought a Mad Dog 16x DVD It will not burn a cd or dvd :a and I cant get the drive to upgrade from the firmware and I have went and exchanged the drive twice thinking it was a faulty drive well I am a newbie so have no clue really :slight_smile: anyway I was on tech support for like 4 hours and they said well there has to be a conflict but I dunno what it could be its a brand new HDD with a fresh loading of xp all updated and theres not much else loaded the firmware version it has now is 2.F6 and I need all the help I can get pleaseeeeeeeeeeeeeee I am begging! :bow:


#2

Latest firmware is 2.F9 or something, but if you can’t do anything with the drive yet, try various things first of all like installing the drive on another PC, re-installing OS making sure all problems are sorted out. If you have already received two replacements for the same model, it’s highly likely your system is still wrong.


#3

Moved to NEC forum.


#4

I just bought mine a few days ago and it works fine with Recordnow that I already had in the pc. I haven’t tried the Nero stuff yet that came with the drive. Dvdidentifer and a couple of those types of apps work fine too with the drive. Fw flash worked fine too. 2Fa is the current Maddog fw as of a couple of days ago.

Obvious things to walk through-

Does the pc see the drive as a device?
What program did you use to try for the burns…Nero? Something else?
Did you try various media for burining.
For the fw flash, did you download and save to c: drive first, then double click to flash?


#5

Angelwings, maybe you can post us some more information about your hardware as well. A new HDD and XP is a good start, but there is more to it… :wink:

Download Nero Info Tool and CD/DVD Speed from here. They will come handy in many ways, also when troubleshooting in future. :slight_smile:


#6

Well my computer is a 1.1 ghz and it has 512 ram and I have windows xp and all the updates I tried to burn it with the nero software and others they all freeze :frowning: I am going to format my HD and try another install and see if that will help?
Thank you
Rachelle


#7

…and your firmware is fine until all is working. Mine was shipped with 2F6 as well and I kept it there for days. Now it is 2FA. BUT, you need to fix whatever is wrong with your PC first. The firmware is the LEAST of your problems.

P.S. By updated XP do you even have sp2 installed?

Also, does the drive show up in device manager?


#8

Yes I have sp 2 and the drive shows up in the device manager :confused: I just formatted the hard drive and have nothing loaded but the windows xp , Nero , and the sp 1 for windows… is it possible for conflict with the mother board itself?