[M2] Sony Memory Stick Micro 1GB, can't slow format!

Just bought a new M2 1GB card. I try to slow format it, and fails at the end. Tried with Fat & Fat32, tried on my card reader and my mobile. :sad:

Did i get a faulty card? Any program can do a check on that? I usu just do sfv on files!!

And it’s only 911MB avail., i was expecting 953MB…
bloody $ony :a

ive never had a problem with sony’s memory cards… what do u mean by slow formatting it?

“slow formatting”, just not quick format…

Be warned! There are masses of fake Sony memory sticks on the market. If you got the memory stick cheap the chances are that it’s a fake and there is virtually no way to tell them apart, even the hologram is the same. The only trick to detect a fake from a real one is sometimes the available memory and the way the plastic packaging is welded.

See this excellent article that saved me from buying a fake:
http://reviews.ebay.com/FAKE-Sony-Memory-Stick-Pro-Duo-MagicGate-Cards-Exposed_W0QQugidZ10000000001236041

Coming from Australia, here’s one from OCAU
http://www.overclockers.com.au/wiki/Fake_Memory_Cards

It has been said that OCAU’s is quite comprehensive compare, hope this saves someone else any troubles :slight_smile: