Ltr-48125w wont read discs

vbimport

#1

New to this forum, so I hope I post in the right spot…

Anyway, overnight basically my lite-on ltr-48125 48X12X48 cd rw decided it will read about 10% of the discs I put in it. I tried games, those all work fine. I tried cd’s i recently burned with that drive, and some work.

But the vast majority of the cds I put in do absolutely nothing, a little bit of flashing from the light and it just sits there. Acts like nothings in the drive. I just updated the firmware, just in case it would help and it did nothing.

I’m not even sure how to begin troubleshooting this problem, and I’m worried the drive is shot…

Anyone have any ideas at all?


#2

Now that I’m looking at it, the light flashes green and fast when I put it in, stops for a second, flashes green 3 times slowly then stops and flashes 3 more times and goes out.

This is so weird…


#3

Sounds like the drive is having problems reading the discs hence all the flashing lights then because it can’t read the disc it presumes the drive is empty. Sounds like the drive is on its way out, best thing to do is try it in a different machine if possible then if it’s still the same it’s time to buy a new drive. Does it only have problems with burnt media? Sorry but your post is a little unclear. If its just burnt media it could be cheap/bad media, what media are you using?


#4

Thus far it is only burnt media that does it, but this is media the driver burned itself, as well as media that has worked in the past.

I tried a variety of different types of burnt cds, and right now not whole lot will work at all…


#5

have you:
checked DMA? Tried reinstalling ide controller? If you are using via chipset drivers, reverted to msdrivers? I’d check these before pulling it and trying in another system.