LTR-24102B was detected as PIO Mode 4

vbimport

#1

Dear all,

Need some advise!

Just bought the above drive today and my PC cannot detect it UDMA33.

My computer spec: ASUS CUSL2, BIOS: 1009

I am using UDMA66 80 pins flat cable.

My harddisk at Primary Master can detect correctly as UDMA-5

Intel(R) Application Accelerator provided the following information:

Secondary Slave: LITE-ON LTR-24102B
Model: LITE-ON LTR-24102B
Firmware: 5S57
Device Type: ATAPI - Removable - CDROM
PIO Mode Support: 0 - 1 - 2 - 3 - 4
DMA SW Mode Support: No Support
DMA MW Mode Support: 0 - 1 - 2
UDMA Mode Support: No Support
Default Transfer Mode: DMA MW-0
Current Transfer Mode: DMA MW-2
Transfer Mode Limit: No Limit
Cable Type (Device): 40 Conductor
Cable Type (Host): 80 Conductor
PIO PPE: Disabled
UDMA Control Register: Ultra DMA Mode Disabled

With reference to the above, I've noticed that Cable Type (device): 40 Conductor. Could it be the culprit?

Thank you for any suggestion.

Richard


#2

I had a similar problem once and I no matter how I moved the drive, switched cables etc I couldnt get it out of PIO.

First, try disabling Intel Application Accelerator, select DMA and restart.
If that doesn’t work, try switching some cables.

If you’re on XP, do this, this saved me: mark the secondary IDE channel (you should have your burner on this channel unless they are already full) in the device manager, and delete it.
XP will reinstall it when you reboot. There, DMA should be enabled.


#3

Originally posted by Airhead
[B]I had a similar problem once and I no matter how I moved the drive, switched cables etc I couldnt get it out of PIO.

First, try disabling Intel Application Accelerator, select DMA and restart.
If that doesn’t work, try switching some cables.

If you’re on XP, do this, this saved me: mark the secondary IDE channel (you should have your burner on this channel unless they are already full) in the device manager, and delete it.
XP will reinstall it when you reboot. There, DMA should be enabled. [/B]

The computer initial BIOS start-up screen already shown the drive as “Mode 4”.

Switching cable with harddisk, the harddisk drive detect correctly as UDMA-5. Concluded I/O port and cable is working.

Will try your advise on deleting Intel Application Accelerator.

By the way, I’m using Windows 98 SE.

Thanks.


#4

Originally posted by imm1900
[B]

The computer initial BIOS start-up screen already shown the drive as “Mode 4”.

Switching cable with harddisk, the harddisk drive detect correctly as UDMA-5. Concluded I/O port and cable is working.

Will try your advise on deleting Intel Application Accelerator.

By the way, I’m using Windows 98 SE.

Thanks. [/B]

I’ve removed Intel Application Accelerator and with DMA ON for the drive.

Nero CDSpeed2000 testing shown Interface Burst Rate: 12MB/s.

May I know your rating for the above?

Currently, is you BIOS still detect as PIO Mode 4?


#5

I too get 12MB/s burst rate. And my BIOS display’s “CD/RW ATA-33” when booting up.
It seems like you have solved your problems, right?

If you want to be 100% certain that DMA is on download and run Nero IntoTool from www.cdspeed2000.com


#6

Originally posted by Airhead
[B]I too get 12MB/s burst rate. And my BIOS display’s “CD/RW ATA-33” when booting up.
It seems like you have solved your problems, right?

If you want to be 100% certain that DMA is on download and run Nero IntoTool from www.cdspeed2000.com [/B]

Is UDMA-33 suppose to transfer at 33MB/s?

Maybe I’m wrong.


#7

UDMA33 (or ATA33) have a theoretical upper limit of 33mb/s.
They very rarely reach those numbers anyway, since they are mostly used by floppy’s and cd-rw’s.

It’s not supposed to transfer at that speed, and it will never ever get over it. It’ll keep somewhere in the middle.


#8

Originally posted by Airhead
[B]UDMA33 (or ATA33) have a theoretical upper limit of 33mb/s.
They very rarely reach those numbers anyway, since they are mostly used by floppy’s and cd-rw’s.

It’s not supposed to transfer at that speed, and it will never ever get over it. It’ll keep somewhere in the middle. [/B]

Thanks for all the assistance.

Guess I’ve to stick to what I got!