Ltr-24102 keeps ejecting

vbimport

#1

Hi all,
My problem is I have burned 6 or 8 cds with no problem in the 14mo.s I’ve had this pc, Now when I place a cd (music, data, ect.) in the tray it closes for a few minutes then ejects it. If I place a blank cd in it stays and seems to burn or copy or whatever I am trying to do. BUT, after it is done and ejects when I reinsert it, it still shows as having a blank disc. Device manager says alls cool.So does the properties? Any Ideas.:confused:

              Thanks in advance,
                                    Rick

If the lens is dirty could that cause this?


#2

Maybe the lens is dirty…but I doubt it.

Have you tried updating the firmware?
Tried other CD-R disc brands?
Tried other writing programs?
Tried updating your writing software?
Do the written disc work in other drives or is it just empty?
How is the drive connected (Secondary master?)? and is DMA activated for the drive?

Could you possibly try the drive in another computer?


#3

OC-Freak, thanks for the quick response. I apologize for taking so long to post a reply. This is just the first time I’ve been able to get on line. Anyway here is some more info,

  1. " Have you tried updating the firmware?" I checked at Dell and have the newest firmware 4DS3. Do you have to re flash sometimes even if it was working before? Their is a firmware 4DS7 I believe, but Dell says it is for the optiplex not dimension and not to use it. I have it downloaded and ready to flash but thought I better check around first. It’s for the same exact burner I beleive it should work. Any thoughts?

  2. “Tried other CD-R disc brands?” No these were working also. Can that change?

  3. “Tried other writing programs?” No, again it was working. I did
    try burning from music match juke box, windows media player,
    and direct copy. Does roxio still do the work in the back
    ground?

  4. "Do the written disc work in other drives or is it just empty?
    When I go to My Music pick a song,and pick copy to audio cd
    every thing works as it should. When I try to play it, it
    shows it as blank. When I put it in my home system it shows all the info ; # of tracks, duration, ect., and plays just like it should? :confused:

  5. “How is the drive connected (Secondary master?)? and is DMA activated for the drive?” I found this message in the dma controller Properties : “No drivers are installed for this device.” Could this be my problem? I’m having trouble finding out if DMA is activated. It is secondary master

I don’t have another system to try the drive in at the moment. Thank you for your time. And once more I’m sorry about the time it took to check my post. Especially after your timely response. Any help is greatly appreciated and much needed. Later,
Rick


#4

I’m just getting this post back on top since I was unable to reply for awhile. I hate to go buy another cdrw and find out it still won’t work so any help is very much appreciated
Thanks,
Rick502


#5

This happened to my LTR-24102B. No cleaning or flashing fixed it, so I assumed that the lense was done and I used it as an excuse for an upgrade.


#6

I’m afraid thats what I need to do also dhc014. Oh well their goes my new hhd or ram. I’ve been trying to decide which upgrade to do first. And waiting to see if this drive could be straightened out since it still burns it just doesn’t read. Guess I know what to upgrade now. Anybody know a good deal on a dvd-rw.:bigsmile:

Thanks,
Rick502


#7

OC-Freak asked if my dma was enabled. I finally found what I was looking for in sys. info. it says the following ;
“Channel 2 standard floppy disc controller
Channel 4 DMA controller "
no mention of my cdrw drive or anything else. How do I activate it? I also found this under DMA properties : “No drivers are installed for this device.” but when I went to the driver tab it said:” No drivers are required or installed for this device" I don’t know? :confused:
Thanks,
Grasping at straws :wink:


#8

You can find out how to enable DMA by reading this.

If that doesn’t help and you are prepared to buy a new CD-RW, try backing up your existing firmware with mtkflash, and flash to the newer version available from Dell (even if it says it’s for the Optiplex). After all, you can’t hurt anything if you’re already prepared to throw it away. My guess is that that firmware version will work, even if it doesn’t help the problem. And if it doesn’t work, you can always restore the backup you made with mtkflash.

If you do end up needing a new CD-RW drive, I’d recommend an LTR-52327S. I have two of these drives, and they’re really nice! :smiley:


#9

Rick,

Let us face the truth - your drive’s quite obsolete.
So don’t waste your time and get a new drive - those are pretty much [COLOR=blue]affordable nowadays.
I used to buy 1 or 2 CDs for this kinda money.[/COLOR] :smiley:


#10

Try the link CDRecorder gave…it’s very useful.

And make sure that intel application accelerator or similar drivers is not installed. :wink:

The only time I had similar problems was with an abit mainboard (may be other mainboards as well) and an LTR-24102B…but then the tray always kept ejecting. I upgraded the firmware to the latest version and now the problems disappeared more or less at least.

Don’t worry, just try the firmware, even if it says for optiplex… :slight_smile:


#11

My thanks to all,
I kinda figured I was beating a dead horse. BoSkin I know its obsolete the thing is I bought it new from Dell just over a year ago and used it less than ten times. A couple of months sooner and it would have been under warranty. :Z Thats the only reason I’ve put so much time in it. Thanks for the link I’ll check it out now.

Thanks everyone,
Rick502


#12

Still, why not try out the Dell firmware, as OC-Freak suggested? At this point, what can you lose?


#13

I am definitely going to try flashing as OC-Freak and you(CDRecorder) have suggested. I just need to run out any get some floppy disc’s after I put the little Yard Ape down for the night. I’ll post the the outcome asap.
Thanks,
one with fingers crossed
I almost forgot when I found the secondary IDE controller properties (thanks CDRecorder)under device 1 it had
device type: auto detection transfer mode: DMA if available
Current transfer mode: not applicable
device 0 was fine device type was dimmed w/ auto detect
trans mode DMA if aval.
current trans. mode:Ultra DMA mode 2
Is this correct?
thanks again


#14

Assuming that Device 0 (i.e. master drive) is your Lite-On burner, that is right. Ultra DMA Mode 2 is the best transfer mode for the drive. I hope that the firmware update helps! :smiley:


#15

Got floppies, Got flashed, Got cd-rw!
Thank you all, I’m up and running again.
OC-Freak and CDRecorder :bow: thanks for the patience. Since you all have helped so much and since everyone needs a good laugh and since I can laugh at myself, I am going against OC-Freak’s and Mark Twain’s advice and open my mouth when I should just keep this to myself. Keep in mind I’m not a fool just foolish sometimes. I downloaded the 4ds7 firmware from a link on a post from the Dell Tech who said only to use it w/ the Optiplex. Well before I flashed it I searched the dell site once more and found the original file, here is part of what it said:

Fixes and Enhancements :

This FW removes the Autoeject feature.
aaarrrrggghhhh! !
Hope you laughed as hard as I cried. :stuck_out_tongue:
Thank you so much,
Rick502
I don’t know that much about the PC Tech Dept (DuH). But if you have any questions regarding Orthotics or Prosthetics I’d be glad to help. :wink:


#16

Well, I’m really glad to hear that it’s working again! :smiley: You’re welcome; I’m glad I could help!

That is interesting that one of the features of the new firmware is known to fix this problem. I guess Dell must have had others with the same problem. Maybe they’d only seen the problem in Optiplex computers, so they didn’t designate the update for yours. In any case, I’m glad you didn’t have to buy a new drive!