LTR-12102C bad f/w upgrade HELP! please

vbimport

#1

I have a LTR-12102C drive, and I had flashead several time with mtkflash successful, but a pair of minutes ago I flashed again and when I got the "reboot your pc" I rebooted inmediatly without waiting the drive stop blinking the led.
Now the led is always on (EVEN IF A DISCONNECT THE POWER CABLE) and neither windows or the bios recognizes the drive.
If I use again mtkflash it seems to flash succesfull, and even I cand read back the firmware from the drive, but nothing changes the led stills on.
I´ve noticed that mtkflash the erasing in mtkflash is now inmediatly instead showing a progress display.
PLEASE HELP!!!!!!!!!!


#2

Which version of firmware? Why did you have to use mtkflash to flash the drive? You could have just used the windows flasher.


#3

I thought mtkflash wouldn’t work on the 12x drive.

Try the jumper trick (Search for the relevant post by Boskin).


#4

It works on the “C” version i think. IDK why. the firmware has the same exact format as my 24102B which has an mtk chipset.


#5

Originally posted by burnproof
[B]I thought mtkflash wouldn’t work on the 12x drive.

Try the jumper trick (Search for the relevant post by Boskin). [/B]

I searched for Boskin post, but I didn´t found the one you are referring to. Can you be more specific please?

Btw I think this drive can´t use the jumper trick, since the unused jumpers has this configuration:

| | |
| | |


#6

Originally posted by dhc014
Which version of firmware? Why did you have to use mtkflash to flash the drive? You could have just used the windows flasher.

Any firmware version fails now.
I can flash, I can read the flash contents back to the hd and they are 100% perfect, BUT THE GREEN LIGHT NEVER TURNS OFF, and the drive isn´t recognized :frowning:

What can I do?


#7

Try to flash it on another computer.

If that do not work…get a new drive…


#8

The jumper trick is posted here:

http://club.cdfreaks.com/showthread.php?threadid=47396&highlight=Jumper+trick

True, it may not be possible to use it for the pin configuration you have listed.

However, there was another post recently with similar pin configuration. The user in that case apparently shorted / jumpered pins at random. Finally he got the drive to work.

And please don’t ask me to be more specific yet again… I don’t have time to search for that thread again :slight_smile:


#9

Yes he said this jumper trick worked:


*==

== is the jumper.

I do not know if it worked though.


#10

According to Lite-ON guys:

Hi,

if the LED is always on it means that the F/W of the drive is gone. It will
not accept any commands anymore. That’s why you can reflash/reset it
anymore. Sorry, you have to swap it to get a working one.

Christian

But this is false, cause I can use mtkflash succesfully.
Btw I don´t see what it´s the technical reason that made sme drives back to live in some computers and not in others.


#11

I had a dead LTR-32123S that didn’t want to work…tried everything. Tried flashing on both my computers which have via chipset on the motherbard…same result.

Moved the drive to an old Pentium pro 200 computer and flashed. Voila worked immediately. (this computer have an old intel chipset).


#12

Originally posted by OC-Freak
[B]I had a dead LTR-32123S that didn’t want to work…tried everything. Tried flashing on both my computers which have via chipset on the motherbard…same result.

Moved the drive to an old Pentium pro 200 computer and flashed. Voila worked immediately. (this computer have an old intel chipset). [/B]

Did you have the same problems I have, or mtkflash only left you flash with the old pentium?
I can flash, and even read the flash-rom from the drive without problems. But the green led is always on.

I´m using a Asus P2B mobo, (Intel440BX chipset) with a Celeron 700

Thank you for your help


#13

I tried to flash on an older computer, but it did exactly the same :frowning:


#14

Seems like you have to get a new drive then…:frowning:


#15

Yep :frowning: … I promise I´ll never flash again any other drive :stuck_out_tongue:
Well, at least now cdrw burners are very cheap, Sony 24x10x40 63€

Thank you to everybody for helping me.

Btw: THE WAIT TIME UNTIL THE LED STOP FLASHING SHOULD BE ADDED TO TE TUTORIALS…if you reset inmediatly (as mtkflash ask you) the result is a nice, useless, and broken drive