LTD163 won't play DVDs after reinstall and firmware will not work

vbimport

#1

hey everyone!

I recently had to reformat my hard drive…unfortunately, I couldn’t find the Cd that had all my device drivers on it, so i’m trying to do it all by hand.
My windows XP is using generic drivers for my liteon LTD163, but for some reason, it won’t play DVD’s, interactual player says that there is a bad encoder…so I go through troubleshooting and all that…Turns out I think I have no firmware for my dvd rom, so i try to download the firmware from here, and after unzipping the file (to my desktop, maybe that’s the problem, i don’t know) it says that it doesn’t match the model type…any suggestions on what I could be doing wrong?


#2

Hmm… Sounds more like a software/decoder problem to me. Is your drive able to read data DVD’s? Are you using the commercial version of ‘interactual player’? If you’re not please keep this in mind:

Your drives firmware is stored in a chip and does not disappear just like that. So I don’t think that is is your problem. Instead I’ll adwise you to download a free trial of ‘Powerdvd’ or any other decent player with a builtin decoder. Install it and see what happens. Good luck. :slight_smile:


#3

Yessir, I had already installed the decoder from power dvd, was able to find THAT cd that came with my computer :stuck_out_tongue:

I was looking at the drivers that is running the drive atm…it’s being run by the windows generic CD rom drivers…could this be my problem?

and if so, where can I get the drivers I need?

liteon.com doesn’t carry the driver for LTD163, and neither does Dell, where I bought my computer.


#4

Internal drives don’t need their own drivers- whatever Windows is using is fine.

You can go here http://digi.rpc1.org/0page.php for 163 firmware if you like, but as beer dog said, that doesn’t seem to be your problem.


#5

Did you install ASPI and also uninstall PowerDVD and reinstall it…

Also have you installed Interactual Player???


#6

what is ASPI?


#7

Are you able to watch DVD’s with ‘Power DVD’?
Did you check your system on ‘InterActual Technical Support’ site?
Or perhaps you can get some help here .

ASPI simple explanation.
ASPI advanced explanation.


#8

nope, i have no ASPI installed on my computer at all.


#9

and no, when you try to watch a dvd with either power dvd or wmp it will freeze and eventually encounter an error


#10

just some extra information if it might help…
The drive will still play normal and audio cd’s…it just won’t play any dvd’s. Every other program besides interactual that tries to access the drive for a DVD freezes and then encounters an error. Interactual gives the following message:

Error PL4013: Playback failed due to a problem with the video subsystem. You may be using an unsupported display mode or your system may not have a working decoder installed. Please ensure that your DVD decoder is functioning properly by launching it from Start | Programs. Click “Help Online” for details on how to correct this problem

Now for stats and stuff.

Decoder Provider: CyberLink Corp.
Decoder Type: CyberLink Video/SP Filter
Decoder Name: C:\Program Files\CyberLink\PowerDVD\clvsd.ax
Decoder Version: 3.5.0814
Decoder Driver Date: August 14, 2001, 02:29 PM
Navigator Name: DirectShow
Navigator Version: 1
Is DVD Device Found: Yes

Screen Resolution: 800 x 600
Color Depth: 32 bits per pixel
Direct X Version: 5.3.0000000.900 built by: DIRECTX
Graphics Adapter: VGA
Graphics Adapter Version: 16384

Installed Audio: Intel® Integrated Audio
Audio Muted: No
Audio Installed: Yes

Computer Type: MS-DOS or PC-DOS System
DVD-Rom Drive: D:E:,
Operating System: WINDOWS XP
OS Version: 5.1
Processor Type: PROCESSOR_ARCHITECTURE_INTEL
Browser Provider: Microsoft Corporation
Browser Version: 6.0.2600.0000
InterActual Player Version: 2.05.10.0325
Low Power Timeout: Not Active
Screen Saver Timeout: 0 minutes
Screen Saver Active: No

the drivers that the dvd rom is using atm are the generic CDROM drivers. They are: C:\WINDOWS\System32\storprop.dll
C:\WINDOWS\System32\DRIVERS\redbook.sys
C:\WINDOWS\System32\DRIVERS\cdrom.sys

I tried installing the ASPI like you said I should look into, but it didn’t help.

i know some guys said that if it’s an internal device, that it wouldn’t matter what driver was running it, but if it was just a cdrom driver running a dvdrom driver, could that explain why it will read CD’s and not DVD’s?

I’m just so running out of ideas…any help would be appreciated…and the help that has been given is already much appreciated :bow:


#11

oh, btw, i also tried lowering the colors and the resolution of my desktop like interactive recommended to deal with the might be an unsupported video mod, but it didn’t help either

/yank out hair


#12

Well…I’m no expert but it seems to me that your decoder file (clvsd.ax) is quite old. I’ll suggest that you uninstall ‘PowerDVD’ and reinstall a newer version. I also recommend to update DIRECTX and your windows to Sp1.

Good Luck :slight_smile:


#13

there’s a new DX out already? i just up graded to dx9.0b not too long ago

upgrade to windows sp?

and I will look into trying to get an updated decoder.


#14
  1. Sorry, 9.0b is fine

  2. Service pack 1 for windows XP


#15

Alright, here’s the deal…I downloaded the service pack.

However, I tried to update my powerdvd and it said that my powerdvd is either not installed or is too outdated i’m guessing it’s outdated

Also, i downloaded the latest firmware. GH5S and double click it, and it keeps saying that I have the wrong model type…at first I wasn’t so I confirmed it with Dell, but it is indeed a LTD163. Am I doing something wrong with installing the firmware? I read somewhere I think that firmware had to be installed from MSDOS so I tried loading it from opening windows in command prompt mode (they said you couldn’t do it with command prompt with windows on) and no text or anything happened, it just read the file and came back up with the a: prompt

sooo confused!


#16

I understand your confusion. Seems like you can’t install ‘PowerDVD’ because you’ve been using an earlier version of that program?? Hmmm… I really don’t understand their policy. Why the hell won’t they let you try a newer version of their product? Why don’t you try to install WinDVD instead? I never used that proggie myself, but it might do the job.

About your firmware troubles: it looks like dell have their own firmwares for the LTD-163. That is properly why you’re not allowed to flash your drive. There seems to be a workaround for that however. Just go to this site and do some reading. Before flashing be sure that you have read the instructions carefully. Also keep in mind that a bad flash might destroy your drive. I do NOT recommend you to flash your drive, at least not as the first step. I think you’ve got software/decoder problems, which isn’t related to your drive.