Ltd-166s and DriveInfo V2.1

I have just downloaded Rpcde.exe Region Free for my ltd-166s DVD player. After installing Rpcde.exe I rebooted then started Drive Info V2.1 up and it says,

Problem with ASPI Layer detected
Due to this problem the DVD player program will probably detect your drive as region protected and you will probably be unable to play DVD’s possible solutons:

  1. Turn off DMA support for the DVD drive.
  2. Is all about having a VIA chipset mine is Intel 815E chipset

Has anyone else had this and what do I do next I have tried turning DMA off but it still says the same thing and I always reboot after any changes.

Thanks

Belly,
We need to know what OS you are running.
If it is Windows XP, you will need to run the RPCDE utiliy in windows 98 compatibility mode.
Right click on the unzipped utiliy
click properties
then click compatibiliy
Choose run this proram in windows 98 mode.
This should get your LTD166S region free

Hi RJB0388
Thanks for your reply the OS this way is new to me it is Windows 2000 Pro, is there any settings for 2000 that has to be changed in order for it to work as region free.

Thanks

Can anyone help with this problem please.

Are you running the RPCDE utiliy in the windows 98 mode?

If you are and you are still getting the same message in the Drive info tool then go to ythis link http://aspi.radified.com/

and download the adaptec ASPI checker ver. 4.60 install the program to see the condition of your ASPI layer. You might be missing some files. if you are, on the same link, you can download force ASPI. Read all instructions on there web site. before you force ASPI make sure you back up your original ASPI configuration. After all this is done you will be region free. You can also check out Mango’s page http://digitri.tk/ He has an excellent site on how to make your LiteON DVD region free.

I would love to add some pictures to this reply to further explain what to look for but, for some reason I am not able to. So if a moderator happens to view this post I would appreciate it if the forum could turn on my attatchments function. Thank You

And good luck Belly. Have fun

RJB0388 I will give that a try in a bit. I can help you with your attatchments function. Go to the top of this page and click on the Profile tab once in there click on Edit Options, in there you can activate or deactivate all your settings. I will let you know how I get on with the region free, its always handy for other people to read with the same problem as me. Just looked and I don’t have
Win98 compatibility mode in the menu thats what is giving me all the problems in making the drive region free so far as I can see.
Thanks

Finally got it working, Right click on the Rpced.exe, select properties and then select the Windows 98 compatability mode. (But this won’t work in Windows 2000)

After a lot of searching I finally came accros this:

In Windows 2000, I think you have to create a shortcut to the Rpced EXE before you can choose a compatability mode to run the EXE in. So make a shortcut to rpced.exe, right-click it, choose Properties and then choose the Win98 compatability mode on the compatability tab. That should do it.

If the compatability tab doesn’t show up, don’t worry, I don’t think the tab is enabled by default. Open up a command prompt and type regsvr32 %systemroot%\apppatch\slayerui.dll to enable it.

I did all of this and it finally works I now have a LTD-166S Drive region free. Hope others who have got this same problem can use this to make their drive region free as well. Good luck and thanks RJB0388 for all your help.

:wink: :bigsmile: