LTD-163 and LTR-40125W woes! Big time! :(

Hi!

I sincerely hope someone can help me. I’ve noticed a couple of similar posts in this forum, but I seem to be the first to get the “double whammy!”

Anyway, I’ve just finished building my latest rig about a week ago, and now I find myself wasting HUGE amounts of time troubleshooting, guess what… my Lite-On CDRW and DVD drives!

It all started with the DVD drive, a Lite-On LTD-163, filling up my event log (I’m running WinXP Pro) with one timeout error after the other (Event ID 9, “The device, \Device\Ide\IdePort1, did not respond within the timeout period.”) Oh, and I get the occasional bad block error too (but only two or three times)!

My shiny new CDRW drive, a Lite-On LTR-40125W, didn’t exhibit these errors. “At least the CDRW drive is fine,” I thought to myself. Oh boy, was I ever wrong! A couple of days ago I had a friend over. At one point we had some stuff to be burned on CD, and since I hadn’t tried burning anything on the new drive yet, I was really looking forward to how it would perform. Well, turns out the Lite-On CDRW is a great reader with just a tiny flaw; it can’t detect blank media! Well, woohoo! NOT!!!

So, since then I’ve really done nothing but troubleshoot these damn drives. I’ve already changed the IDE cable several times. Originally I used a 40 conductor IDE cable right out of the box. Since then I’ve tried two brand new 80 conductor cables. I’ve also switched the positions of the drives. All to no avail.

I have of course also flashed the latest firmware on both drives, and took great care in doing so (Windows PIO for the CDRW and pure DOS for the DVD drive). Problems are still there. Or rather, since flashing the CDRW it can now magically detect blank media. Now I can write CDs, if that is what you can call coasters!

Yup! When I check a burned disc with Nero CD Speed’s Scandisc feature the first 30%-35% are usually OK, then it goes downhill from there, including a couple of unreadable sectors. And that is when I’m checking the discs with the CDRW. When using the DVD drive I get decidedly more errors. By comparison, any disc (of the same brands) burned with my previous TEAC R56 writer is read at max. speed and with no error whatsoever by both the DVD and the CDRW drive.

By the way, all write tests were conducted using the included Lite-On media as well as what I consider good branded media like TDK and Kodak (although I mainly use the Lite-On CDRW disc now after my first box of coasters.) Also, no higher writing speed than 12x (where applicable) was ever attempted, and several burns were conducted at 4x. Still, no drive was able to properly read the written disc, not even the writer itself. Also did simulations and tried writing with SMARTburn turned both on and off. Nero (both the shipped 5.5.8.0 and the recent 5.5.9.0 versions) never displays any errors whatsoever, so according to Nero the discs should all be fine.

All firmware are the official versions, by the way, and I’ve also read out the firmware, so I could do a binary compare. Which brings me to another point; has anyone ever compared a “pure” extracted firmware (using litefirm.exe) with a flashed one or with the one in the appropriate RAR file? They are far from identical! The flashed and RAR ones are similar (e.g. for the WS05 firmware), but both of these are pretty different from the “pure” unflashed one. Is that just me, or does that sound decidedly unhealthy?!?

Anyway, now that the CDRW drive can recognize blank media, I’m treated to a new error (CDRW drive only): Event ID 51, “An error was detected on device \Device\CdRom1 during a paging operation.” Isn’t that special?

I’ve also tried to install the latest (non beta) Intel Application Accelerator drivers for my i845 based board. Only difference is a change of “source” type; with native WinXP drivers the source was “atapi”, now it’s “IdeChnDr”.

I feel I’ve tried everything I can think of (short of returning the drives, which is now next on my list.) I’ve pretty much ruled out the motherboard, since the system works fine otherwise, but maybe I have overlooked something. If anyone has any idea whatsoever I’d love to hear from you.

Regards and TIA!
Az

For the sake of completeness, here’s a short list of my hardware (everything is run in spec):

motherboard: ASUS P4B533-E rev 1.02 (BIOS 1007E flashed, originally 1004E)

processor: Intel Pentium 4 (Northwood) 1.6GHz in-a-box

memory: 768MB Kingston ECC DDR RAM (256MB + 512MB module)

graphics card: ASUS V8420/TD Geforce4 Ti4200 128MB DDR RAM with TV-out and DVI-I

sound card: Creative Labs Audigy Player

hard drive: Maxtor D540X 120GB (model 4G120J6) (primary master)

DVD ROM drive: Lite-On LTD-163 (firmware GH5N flashed, originally GH5K) (secondary master)

CDRW drive: Lite-On LTR-40125W (firmware WS05 flashed, originally WS04) (secondary slave)

floppy drive: ALPS generic floppy disk drive (yes, I still use floppies! :))

(and sorry for the humongous post… :))

A few things, in case you haven’t tried:

  1. Do not install the Intel App Accel… drivers or any other additional drivers. Stick to whatever came with your motherboard.

  2. You mention that all hardware is run in spec. Crosscheck your clock settings again. (If I was using the Asus board and the Northwoods (particularly the 1.6A), I’d definitely be overclocking the system :stuck_out_tongue: . Overclocking can adversely affect your drives and peripherals (PCI components), which I’m sure you’re aware of. )

  3. Revert to the previous BIOS version and check your drives again.

  4. Disable any antivirus apps and check your drives again.

  5. Disable the IMAPI service.

  6. Try SP1 Beta Build 1068 (NOT 1070 or 1073…)

Not sure about this, but if you’re using a builtin RAID or ATA133 card, try without them.

First I would have tried the drives in another computer (preferrably running another operating system than crashXP).

If they worked ok there I would have considered formatting the computer and reinstalled everything… Would also have considered other OS’es.

To tell the truth I upgraded from windows XP to windows 2000 pro a week ago due to problems with XP and now finally everything seems to be stable.

I had tried XP, went back to 2000 and tried XP with SP1 Build 1068. This seems to be the most stable XP SP so far. While there are some issues, XP is a much improved version now. I’m getting to like it :slight_smile:

First, thanks for your suggestions! :slight_smile:

No, the cpu isn’t overclocked (although I had originally toyed with the idea :).)

As for the motherboard BIOS, I have tried both the 1004E version, as well as the new 1007E (both beta 12 and final, which incidentally are the same :).) Same problems.

The same is true for the CDRW and DVD drive firmwares. Nothing has changed, apart from the fact, that the CDRW drive originally would recognize no blank media at all. BTW, only the DVD gives me the Event ID 9 error, and only the CDRW gives me the Event 51 warning, so even though both drives exhibit error, they’re individual for each drive. I’m not ruling out a common source, though.

As for the Intel drivers, they seem to make no difference in regard to the error. The only difference seems to be, that instead of ATAPI.SYS reporting the error(s) (source: atapi), it’s now IDECHNDR.SYS (source: IdeChnDr). Also, M$’ driver just automatically limit the transfer rate to PIO4, if the timeout error occurs several times. With Intel’s driver I seem to be in control of that. Another thing, I now have two different drivers, which still give me the same error(s). That has to mean something.

I have tried disabling the IMAPI service (not just setting it to “manual”.) Seems to make no difference but logs an error for each time a CD is inserted into any drive (since the system can no longer start the service.) And more errors I really don’t need… :slight_smile:

As for SP1 build 1068, I only have build 1078 and truth be told I’ve been a bit anxious installing it. (Took me quite a while just to get rid of that damn watermark on the desktop, and I only ever started the setup to verify the files. I never installed it.)

The onboard Promise RAID controller isn’t in use. Actually I have disabled it on the motherboard since I have no plans to use it for the foreseeable future.

As for switching the OS. I’ve never really had any problems with WinXP. It’s been rock stable for me (at least on my old platform :)) and I’ve been running it since beta 2. Win2K is the closest alternative, but I like to do other things besides burning, like gaming and Win2K isn’t that great at that. Win9x is (sadly) no longer an option, since it can’t handle more than 512MB of RAM (which M$ is perfectly aware of, but doesn’t want to fix; their “solution” is a settings hack, which doesn’t work, or removing “excess” memory…) Apart from that, Win9x doesn’t have any kind of event log, which is where the problems manifest themselves. And then there’s Linux… :slight_smile:

I should probably check out the anti virus tip, although I’ve run AVP for some years without ever encountering this problem. And perhaps I should try putting the drives into my old rig. I did try moving my old Toshiba DVD drive to the new system, without getting any apparent errors. But then again both event log errors only happen on a periodical basis, not every time I put a disc in. Actually, the timeout issue only seems to happen if there hasn’t been any activity on the (secondary) IDE bus for a long time. Almost seems to me as if the bus or drive goes to sleep and gets a rude awakening… :slight_smile:

Well, look at that! I managed to do another enormous post! :slight_smile:

The IDE Channel Driver files may not by themselves cause any problems, but the IAA does cause some conflicts.

However, I still don’t think your drives can both be dead. In that case, they shouldn’t be recognised as drives on the IDE chain. Which also means that there would be no timeout error.

Have you tried any trojan removers? There might be trojans involved if you have been visiting some sites :smiley:

Another thing to try would be to reinstall XP using the “Upgrade” option. This might clear up the problem.

Check BIOS settings for the secondary IDE and try “User …” option, not the “Auto…” option.

I have the same motherboard… check Control panel - system - hardware - device manager - IDE ATA/ATAPI Controler… and make sure the Intel 8280 ULTRA ATA controller is installed.
The drivers are located on the CD that came with your motherboard.
Roger

I hope these problems are unique, because I gonna buy both drives within a month or 2 (or a newer model writer if it’s out then). :stuck_out_tongue:

But every problem discussed and solved here is information we all can use. Isn’t it great. :smiley:

Hope you’ll find the cause quick and share your experience with us.

Originally posted by Namoh
[B]I hope these problems are unique, because I gonna buy both drives within a month or 2 (or a newer model writer if it’s out then). :stuck_out_tongue:

But every problem discussed and solved here is information we all can use. Isn’t it great. :smiley:

Hope you’ll find the cause quick and share your experience with us. [/B]

I have almost the same drives without any issues on any OS used. Of course my DVD is a 163D instead of a 163. The combination is fine. The key is to optimize the OS for maximum stability and burn it in for several weeks first. I always run a virgin OS install or new hardware at stock to identify any underlying problems before I start to customize. The situation is isolated, you should have no problems with the combination.

A small update on the situation.

First of all, the IAA drivers where installed after I discovered the drive issues, and both sets of drivers (MS and Intel) exhibit the same error, which makes me think it isn’t driver related. And so far the IAA v2.2 drivers work great for me (apart from said problems.)

Second, the IDE ATA/ATAPI controller section displays the Intel 82801DB Ultra ATA controller as it should, and there are no conflicts or other issues. Just for the hell of it I installed the latest version of Intel’s INF update today. I haven’t had time to check for any differences, but I’m not holding my breath… :slight_smile:

There’s one of the errors I can strike off as “solved”, though. I’m thinking of the (rather rare) Event ID 51 issue in regard to the CDRW drive. I managed to extract copies of old log files from my earlier system, and it turns out the Event ID 51 happened there too. Considering that this was on a radically different system setup (ASUS P3B-F board and a TEAC R56 drive connected via SCSI), I’m pretty much putting this issue down to sloppy MS programming. Add to that the fact, that several of my friends have similar entries in their log files too (incl. on Win2K.) I’d bet if you check your system event logs for warnings of that type, you’ll probably find a couple… :slight_smile:

This leaves two unresolved issues, namely the Event ID 9 error for the DVD drive, as well as the poor writing quality of the CDRW drive.

Gonna try the fixed user settings for the CD ROM drives in the BIOS, though. Maybe that’ll work. As for trojans, I run a tight ship! :slight_smile: And no, that wasn’t an invitation to hack my computer… :slight_smile:

At this point I’d still say I probably have been (un)lucky enough to get a couple of crappy drives. And at the price point they’re sold at, that wouldn’t surprise me one bit!

Regards,
Az

I am getting a “Event ID 9” error also…I believe with from DVD drive. But only occasionally. The system will be fine, then out of the blue (meaning nothing at all launched or “happened” to cause anything) the pc will begin to completely freeze for 5-6 seconds, then resume “normal” operation. This, as you can imagine, is driving me nuts! :confused:

I have crawled all over the web looking for anyone else going through the same thing, and this post is as close as I’ve found. If I can do anything at all to help, like comparing settings, hardware…whatever…please, let me know!

Thanks in advance.