Low burst rate using a DH20A4P

About halfway through the transfer test the speed starts going down and I don’t know why. Even when I’m copying a dvd to the hard drive using Alcohol 120% the speed slows down. I’ve tried different dvd’s and flashing the firmware back to stock and it’s still doing it. Anyone know what’s wrong with my drive or how to fix it?

PaulN64007, is your drive in an external enclosure?

Run a burst rate test with Nero CD-DVD Speed.

No it’s internal. Here is the burst rate test


You need to check your DMA:
http://club.cdfreaks.com/f61/troubleshooting-enabling-checking-dma-windows-vista-xp-2000-me-9x-101616/

Also make sure you are using an 80 wire IDE cable.

The Primary IDE Channel shows Transfer Mode: DMA if available and Current Transfer Mode: Ultra DMA Mode 5. The Secondary IDE Channel shows Transfer Mode: DMA if available and Current Transfer Mode: Ultra DMA Mode [B]2[/B]. The Secondary IDE Channel has the 20A4P drive connected to it

That burst rate needs to be at least 23 MB/s. DMA mode is usually Ultra DMA Mode 4 for the A4 drives.

Have you tried another 80 wire IDE cable. Make sure there is no other drive on the secondary IDE channel.

finally found a 80 wire IDE cable. sad to say it is doing the same thing. I even switched the drive to primary and the Transfer Mode is Ultra DMA Mode 2

I have one drive the 20A4P on the secondary IDE channel and the Transfer Mode is Ultra DMA Mode 2. I’ve tried installing the channel but it still remains at Mode 2.

Greetings PaulN64007 :flower:

Have You Tried This?

[QUOTE=darshanjog;342801]Try removing/deleting the IDE Driver (Primary or Secondary) on which the burner is located from Device Manager & reboot.

XP will re-install fresh IDE drivers & redetect the devices. Hope this solves your problem.[/QUOTE]

do you mean uninstalling it and on reboot windows installed it? yes I did that. when I said installing the channel that’s what I meant.

Yes That What I Meant (Letting Windows Reinstall The IDE Channels)

Sorry Just Trying To Help. :eek:

Is You Motherboard Bios Setup Right Regarding IDE Channels …Etc?
http://www.cdrlabs.com/forum/viewtopic.php?t=6645

yeah it’s all set up right. I have the drive set on master and I tried that regedit thing in that link and that’s not working either

I’m still having the same problem. I even got a new IDE cable and still is stuck at dma mode 2. anyone know how to get it back to mode 4?

See if you have wnaspi32.dll in your system32 folder and if you do, rename it to wnaspi32.dlb.

If it helps, check out frogaspi as a replacement.

I have wnaspi32.dll and renamed it. I’m confused about frogaspi. what do you want me to do?

renaming it didn’t work. I figured out what frogaspi is and I tried that and that didn’t work either.

What are your computer specs.?? Do you have an older slower machine cause on mine always all the time

AD-7170A secondary master = UDMA mode 2
AD-7170A secondary slave = UDMA mode 4
And I can get a clean 18x burn on both drives perfect readback
I don’t believe your problem lies in UDMA mode 2 there is nothing wrong with this now if you were in PIO mode that’d be different. I think your problem lies elsewhere. Are your hard drives runnung in UDMA mode 5?? Because that’s where they should be.

Please post your computer specs

Dell 4600 Pentium 4 2.8GHz
Chipset: Intel Springdale-G i865G
Memory: 2560MB DDR400
Video Card: Sapphire HD 2600 XT AGP
IDE Controller: Intel 82801EB Ultra ATA Storage Controllers
Hard Drives: 2 x Seagate ST3250824AS 250 GB SATA-II, one with OS one for storage
Opitical Drive: ATAPI DVD A DH20A4P, I have 2 but only one installed right now
Power Supply: 250W

Both my HDs are running at UDMA Mode 5
DVD Drive is secondary master = UDMA Mode 2

I can burn at 18x no problem at Ultra DMA Mode 2. it’s just the transfer

You need a BIGGER PSU. 250 is way too weak.