Lost DMA transfer mode

vbimport

#1

After burning five consecutive DVDs or so my burner (Sony DRU-540a) started maxing out at ~2.5x. After a little investigating I found out that it was running without DMA. I fiddled with the DMA/PIO option in Device Manger, but to no avail. I’m left with ‘Not Applicable’ under ‘Current Transfer mode:’ when I set it to DMA. It’s supposed to say 'Ultra DMA mode 2’ instead of ‘Not Applicable.’

Any thoughts?


#2

Try looking for and enabling DMA related options in your system’s BIOS.


#3

The only option I have in bios is to auto-dectect DMA. That’s is what I have it set to right now.


#4

I finally got it to work!

After a day of frustration I decided to reinstall the Intel Ultra DMA driver. The driver worked, but oddly enough, it turned off the DMA for my hard drives. It made it difficult to boot into Windows and slowed the computer’s performace. Not liking this, I uninstalled it. Guess what happened? It fixed everything.