Lord of the Rings subtitles

Hi guys,

I’m trying to rip the subtitles from this DVD. I think there are only two subtitles, ‘60 years later in the shire’ (right at the start of the movie) and the bit when she is speaking Elfish.

I’ve had no problem ripping subtitles before, so I’m a bit frustrated, I’ve used Chickenman’s excellent tutorial.

I’ve tried ripping with smartripper 2.41, and selecting every possible stream. Also I’ve tried the internal ripper in DVD2SVCD, and selected the two streams as permanent subtitles, and I’ve also tried them as SVCD subtitles alswell.

I’ve also tried playing the ripped .vob files with windvd4, powerdvdxp, windows media player 6.4, and realone.

Any help is greatly appreciated ! :cool:

Firstly, welcome to the forum.

Have you tried ripping the Subs out with Subrip ? (http://www.subrip.fr.st/) You can then merge them into DVD2SVCD when you hit GO, now select “Add external subtitle streams”. That way has worked for me with troublesome subs.

I don’t think the segments you speak of are actually subtitle streams. Because they still show up when you play the dvd without subtitles turned on. I think they are part of the video and therefore you can separate them.

Did you encode the dvd to another video type? If so, is there some problem where you are not seeing the subtitles you speak of?:confused:


No I hadn’t encoded the .vob files at that stage, they were ripped straight to my hard drive. I don’t think they are apart of the actual video steam either, because subrip found the subtitles.

By the way, there are a lot more subtitles than I had thought!

I tried using subrip like Chickenman suggested. I used the OCR option (can’t remember if that is the name? I’m not at my PC), It found all the subtitles, and I saved them to an .srt file.

Then I ripped the .vob files with only the video and sound streams, and ran DVD2SVCD, and included the external subtitles, however 17hrs later (slow PC) I played the mpeg files with Windows Media Player 6.4, and no subtitles!!!

When I ran DVD2SVCD I choose ‘SVCD Subtitles’ under the Subtitle tab, should I have choosen Permanent?

Any suggestions?

Thanks !

Chosing Permanent will guarentee the Subs to be included but you will not be able to turn them on or off, of courcse. But then all players that can play SVCD’s will play the subtitles. Selectable SVCD subtitles have many problems with many players.