Locked drives

:confused: Several months ago i installed CloneCD on my WinXP Home system.
at the end of the trial, i uninstalled it, but found that my media players could no longer access my cd-rom drives to play audio cd’s.
i re-installed the app and all was well again.
i tried re-uninstalling the other day and used Registry First Aid to clear
all traces of the app ( there were nearly 60 references remaining- some of
which i had to alter permissions for, before i could remove them), but to no
avail.
i get a message from my Creative Media player saying that another process is
holding on to the drive.
windows media player can’t find the path to the cda on the disc
nero media player can’t open the cd-rom
however, the players detect the cd audio and list the tracks.
i can still play dvd’s on the dvd rom and burn cd’s on the cd writer, but
neither will play audio.
does anyone have any idea what may be locking up my drive in this way?
i’d be grateful for any snippets of knowledge you may have on this topic.

jah

cornwall, uk

Here’s an update:

having ensured there are no remains of Clone cd, blindwrite or cd mate in my registry i’ve re-installed an aspi layer, removed both drives from my system and rebooted.
if i reinstall only the drive that was used as a virtual drive (LG DRD8160b) it functions normally except when asked to play audio cd’s - as before.
if i reinstall only my burner (TEAC CD-W540E) it works perfectly !!
if i reinstall both drives, both work normally except when asked to play audio cd’s - which neither will do.

so i’m guessing that a device driver that loads with the LG drive is causing problems for both drives.

is that progress??

:confused:

I had this once on my system without any software but Nero installed. It was the WindowsXP burn service that locked my drive. Do you have that enabled?

I do have the IMAPI COM service installed, but i have tried disabling it and reinstalling the LG drive, but there’s no difference.
The main clue must be the fact that everything works fine without this drive installed and everything worked fine with this drive installed before i removed CloneCD.
I’m about to compare two lists of drivers on my system. one set with the drive installed and one set without. i’m hoping to discover a difference between the two which might point to a problem.
we, as they say, shall see…

on another topic entirely - nearly:-

the reason i originally installed cloneCD was to crack the copy protection employed by BMG on Neptunes Present… …Clones album in order to make a personal copy. Back then, it wasn’t able to do it and i wonder if it is able to do it now. In the end, i recorded the whole album into Steinberg WaveLab Lite and chopped it up into individual songs before burning to a cd.

update:

i am no closer to the truth.

i am so clueless as to where the problem really lies that I am considering a clean OS install.
i wish i had another HD as this would make my life a lot easier. 4 user accounts on this system including about 12 gigs of user data so i’m gonna be here forever backing up this stuff.
Does anyone have any final thoughts before i dive into the deepest darkest depths of the maelstrom that is my HD?? :rolleyes:

  • The LG is PIO Mode only?[]Is everything DMA running in DMA Mode?[]Turn off IMAPI and Auto-insert notification[]>i’ve re-installed an aspi layer Why?[]Are there any unusual Services running? “gear.exe” for example. This is an API from Gear used by Powerquest in its latest products. I have told Gear and Powerquest that DriveImage 7 locks up my disks and opticals every now and then. Run <services.msc> and take a look around; check that IMAPI is “disabled”.[]Chipset Drivers - what chipset and version of drivers? Update to the latest[]Is CDRWin installed?