Liveupdate Not Working

I have suddenly encountered a problem with liveupdate with my Emprex 1008im. Liveupdate has just stopped recognising the Emprex drive (nothing is shown in the liveupdate box & when I try using liveupdate it says “no drives supported by liveupdate on the system”. I have uninstalled & reinstalled liveupdate,also the drive & ide drivers within Windows XP, but it has made no difference. The strange thing is that Windows & other programmes like Nero & Dvdinfopro etc all recognise the drive & firmware (758) ok. The drive also works ok. The only thing I think I have done is have Windows XP service pack 2 installed. Any ideas please?

On the BTC website you can download the updates as an exe file instead.

url http://www.btc.com.tw/english/3-1-4driver_download_dvd_dual.htm

I prefer this as I use a slow line to access the web and it sometimes drops. I would not want it to drop whilst flashing the drive. Also, on my PC I found I have to disconnect my other DVD-ROM drive prior to flashing the drive (It may because I have my RW drive as secondary rather than master).

You can also download similar from http://tdb.rpc1.org/
However, these are “hacked versions” which get around the 5 times limit for region II (say) coding (you need additional software to stop windows software restricting access to other regions). Obviously using 3rd party hacks is at you own risk.

LiveUpdate is for BTC products only. It will only recognize the following Device ID’s for the 1008 series:

DVDRW-IDE1008
DVDRW-IDE1008IB
DVDRW-USB1008UI

I have the same Prob. Liveupdate say´s no supported drive in the system. The exe from BTC homepage is working. My system runs win xp sp2. My son´s system without sp2 can use Liveupdate without any Prob´s. Ithink it is a Problem of windows with sp2.

Just to clarify my original post, my drive is an Emprex(BTC) DVDRW-IDE1008IM & the problem is not flashing the drive, but actually getting liveupdate to show the drive & firmware & download the latest firmware updates(using “check updates”) Liveupdate worked perfectly with this drive until recently (XP SP2 installation?) The reply from “Ratz” is on the right lines.

Re: DVD-RW 1008IB(No Firmware)


Just updated to 1008UI 0059 firmware and all is good!! Live Update now recognises my drive

Just bought a Emprex Dual Layer 16x. Only $47. Manufactured 12/04.
Brought it home. Ran into the same problem as you. Windows XP SP2.
Liveupdate started, but hung in the middle. No popup from the windows sp2
firewall.

Searched google. Found this thread.

I thought I could just disable the firewall, but instead added the program
as an exception, and tried again. Works now. Great.

Here’s how.
Close the hung LiveUpdate…(hitting the x should do it)

Be careful that you don’t point to a Symantec LiveUpdate.exe

start, control panel, Windows Firewall,
Click on Exceptions tab
Click on Add Program button
The LiveUpdate program we want won’t be in the list, so don’t bother
looking.

Just click on the Browse button. You’ll get a popup
Browse to where you installed THIS LiveUpdate. It should be
C:\Program Files\LiveUpdate\LiveUpdate.exe
Select it, and click the Open button.
The popup should close, and then click OK to close the other popup.
Click Ok again to close the Windows Firewall and accept the change

Start, Programs, LiveUpdate (make sure it’s the right LiveUpdate)
to restart it…do all the right stuff, and it should work now.

Tnx for the pointer to SP2 being the differentiator. :bow:

-snowmman :slight_smile:

I can’t seem to get LiveUpdate to run without crashing. I recently installed XP SP2 on my machine with a DRW1004. Seeing as they are no longer posting the firmwares, now you can only get them through Live Update. My problem is when I run the program, it finds a file and downloads it. Then it crashes and says “LiveUpdate has encountered a problem and must close”. this is all before the program shows the drive and such. I had this problem before (when I first got the drive a year ago). So when it came to updates I would just download the .exe files from BTC. Now I can’t do that. Anyone know how to get this program to run without crashing? I already made sure the Windows Firewall has it cleared for access. It will start, go so far and then crash.