Liteon W40125S tray problem

After installing the drive I burned my first disk in 3 minutes. Fantastic! However, since powering off the PC, the CD tray won’t eject.

I’ve tried suggestions from other threads including unplugging the IDE cable from drive, booting up into Windows XP then shutting down, and then reconnecting IDE cable. Still can’t eject tray. (Also did same step with power cable out of drive too).

Tried flashing the drive to ZS0N. Flash worked, tray doesn’t!

Have anyone got any more suggestions before I ask for an RMA?

Thanks.

hmm… i think you should physically open the tray… use a paper clip (straight it out first) then poke it in the hole that is located just above you’re eject button, you should be able to open your tray… and with luck you should be able to open/close your tray normaly… hey pm me… on what happens

I’ve tried that since posting the original problem. The drive refuses to acknowledge the eject button.

The light comes on as though its going to do something, then nothing :frowning:

Has anyone seen this before, or does it sound like a duff drive? It was only alive for 24 hours!

Please!! Has anyone got any ideas? :confused: