Liteon SSM-8515S

Hi Codeguys

I have the Liteon SSM-8515S DVDRW-drive installed in my laptop (FW GSL1). Liteon released a new firmware GS08. I tried to install it but Xflash says:

No matched drive detected!

This utility is only for Slimtype DVDRW SSM-8515S drive.

Detected drives:

1-0-0-0 E:SlimtypeDVDRW SSM-8515S GSL1

I think the problem is that between Slimtype and DVDRW. There isnt any “spacebar” between…

Anyway would be really thankful, if you can help me :bow:

thx in advance
ron

Is you current firmware really GSL1 ? The flasher probably does not like the ‘L’.

Yes… Really weird ~.~


all problems solved thanks to al :wink: :clap:

Hi ronallan22…

How did you solve the problem? I have the same odd on my laptop and the same trouble with the firmware…
Could you please tell how you fixed it? I’ve e-mailed to lite-on and they told I should contact with the laptop vendor because of that gsl1 code. I also e-mailed them but there’s no reply from them yet…
Thank you

Welcome to cdfreaks :slight_smile:
The GSL1 firmware is an OEM firmware, meaning Liteon does not support the drive. All support has to come from the OEM, which is your laptop vendor.
It is possible to flash the GS08 firmware to your drive by using a modified GS08 flasher or by flashing a GS08 firmware binary dumped from a drive running GS08, but this voids your warranty.

Ok ala42 I see. I’ll wait for an answer from my vendor… I hope they support on this issue. It really disturbs me not to use the device properly

Thank you, regards

edit: does adding new media codes also void warranty?

Hey fellas…

I have the same problem. My drive is the same release of ronalan22 (SSM-8515S GSL1), and I need to upgrade and I don´t found the upgrade file on internet or other place.

I found a hacked Gs08, but i don´t know if this file will work properly, because no one posted about it.

Someone have a properly file or solution and post here, please?

Thanks a lot…

Doug

This is extremely annoying as I am the same, trying to patch the damn thing…

OK, I tried a way an it seems to have worked…

  1. download FLASHFIX and UPX.EXE

  2. extract/process the GS09 firmware with FLASHFIX

  3. install the processed GS09.exe

Hey fredoops!!!

It works… it woooooorks!!! :bow: :bow: :bow:

Now my puppet monster arise and I will finally rule this world… ops… err… this is another thing… sorry…

Now the Nero Info Tool shows the GS09 release!!!

I hope that my problems with this drive, finally gone!!!

Thanks to you!!! A lot!!!

Doug

I’ve got the same, crappy problem (8515S GSL1). I was searching for half an hour but I didn’t find anything -_-
Does somebody know what to do? :frowning:

edit 2 Minutes after posting, the guys of liteon released their GS09 Firmware…now I’ve got the GS09-file, but flashfix says something like that:

And again I don’t know what to do :bigsmile:

Unpack it with upx and try again.

Tried to unpack it with the upx.exe from the flashfix release and the newest version (3.0) - both didn’t work. Error message is: CantUnpackException: file is modified/hacked/protected; take care!!!
Tried to unpack it with upx-ripper too, but it also doesn’t work…
I consider to try the unpacked and patched - but “faulty” - GS09-file, I mean…flashfix only unpacks and patches the updater engine and not the binaries of the included firmware :confused:

same here, won’t unpack tried with v1.25w and 3.00w same error message as Eisdieler

i used the gs08hacked then used the lite-on gs09

thats all you have to do guys…

USE HACKED GS08 FIRMWARE THEN UPDATE TO GS0X

Thanks guys!

Yes, I can confirm the

USE HACKED GS08 FIRMWARE THEN UPDATE TO GS0X
method. I used “[B]Slimtype DVDRW SSM-8515S GS08.bin[/B]” with [B]Flash_Utility.exe[/B], then after restart I applied [B]GS09.exe[/B] which now worked as expected.

I have an Acer Aspire 9301AWSMi, with “SlimtypeDVDRW SSM-8515S GRS6” (now “Slimtype DVDRW SSM-8515S GS09”), and from beggining I had problems with reading some DVDs, while my wife’s laptop was reading them smoothly. After a while it started to be very annoying, this is why I finally decided to risk and try this flashing operation.

After flashing to GS08 I already noticed improvments in reading, probably GS09 is better.

Hi, can anyone make a firmware to flash back to OEM, just in case for warranty proposes.
Or at least tell how it’s done, I’ve dumped old one to .bin file. Thanks

Didn’t the utility you used to dump the original firmware to a .bin file also let you flash firmware using a .bin file?
If not, just use the Liteon Flash Utility with your .bin file.

Hi, I have the same “SlimtypeDVDRW SSM-8515S GSL1” driver, but I can’t find a hacked GS08 firmware. Does anybody know where I can download one? I also tried to read my firmware to use OmniPatch on it, my firmware was 2MB in size and OmniFlash didn’t recognize it.

Please, I really need to update my firmware, most of the writeable media I use doesn’t detect or do detect at a lower speed (8x medie being detected as 4x).

Thanks.