LiteOn SOSW-852S. The strangest problem i have seen

vbimport

#1

Greetings to all.

Sorry i didn’t post in “the big SOSW-852S thread”, but i think this is most strange.

To start i will say i am a computer technician (ie experienced with repairs)

I am trying to replace the old dvd/cdrw drive in my laptop:
Its a Mitac 8640 (SIS 650DX, P4 2.8 Ghz, NVidia GForce-460 GO) with a QSI SBW-161 dvd/cd-rw.

I got a totally unused Lite-on SOSW-852s (PCS3 firmware) from an Acer laptop (well known from what i see in here) and i try to install it in my laptop (it fits ok).

1st problem (Solved):

The drive is factory configured to use cable select (CS), which Mitac did not support and did not detect it.
Problem fixed by grounding pin 47 in the drives connector (now recognised ok as master).

2nd problem (NOT Solved):

Inside windows the drive is recognized normally as slimtype Dvdrw SOSW-852S and Nero InfoTool reports the drive OK and fully capable --BUT–

It does nothing. It does not even spin-up. Any disk i put inside is invisible from explorer (the drive reports no disc). Same with dos, same when trying to boot from cd.
When I stick the drive back to the Acer, and it works OK.

I flashed it with other firmwares. PSX1, PST3, and last with the Sony PFS1 crossflashed (following the guides to the letter) but still the same behavior.
Works in the Acer, present but “dead” in the Mitac.

Any clou? I am stuck. It must be a compatibility issue with the Mitac, but what??? (The bios does not allow any setting changes to play with)

Has anyone seen this problem before?


#2

You could try this: Go here, down load the eeprom utility and the IDE Location Changer for Slimtype Drives. Backup your current eeprom with the eeprom tool. Use the Location Changer to set the drive to master.


#3

Allready done that. First thing i did was to backup firmware and eeprom. I have flashed them back, but still… Thanks though.

Some more info:

I tryed to write to a few disks with Nero, and when i press the write button, the drive immediately ejects the disk.

Note that you can not eject the disk by pushing the button on the drive, only with “eject” from explorer.

??? :confused: :confused: :confused: :confused:


#4

One question…

Who can tell me what is MCSE report i see next to omnipatcher reports in the firmware links (perhaps with a link)?
I see it shows the boot code version as well as the firmware version.
Perhaps i find something in that info…

Thanks


#5

Follow the link in my signature.


#6

My god !!!

Please forgive my ignorance friend… :o :o :o :bow: :bow: :bow:

I must look like an idiot now :slight_smile: :slight_smile:


#7

sorry i don’t understand how you found the solution to your problem? :confused: what link that you followed? the MediaCodeSpeedEdit link? I have a similar problem and am totally stuck.
I’ve also tried to swap this drive with another laptop and it won’t boot. not even past POST with the sosw-852s so I can’t even enter the bios screen. I’ve tried changing the ide location from master to cableselect/inverse cs/slave but nothing happens.
I’ve posted this problem in the big sosw-852s thread and hurbetk told me

Well, that’s because your drive is neither Master nor Slave but Cable Select (CS) or Inverse Cable Select (ICS). These two interfaces are not compatible to each other but can be changed by firmware. If your drive has the wrong version, just reflash it to the correct one.

However it is more possible, that your notebook’s BIOS has an ID check to make the use of 3rd party drives impossible. In this case you will need the proper ID in your firmware. With a standard hex editor this is very easy to manage.

I have a questions:
what is the ID check? is it the BootCode of the firmware?