Liteon SOHW-832S and booktype.exe v.1.2.0 don't work

Hi!

I just ask all of you that what might be a problem. I have a few days ago tried booktype.exe v.1.0.4 and it works fine. Then I tried that Quality-Patched CG3E Firmware and then back to official VS0E firmware… Then I saw that this booktype.exe has newer version what I own and decided to try it. When I try execute booktype.exe v1.2.0, it gives me a error “Unsupported Drive Detected! Drive detected but is not supported by this program”. Why that didn’t work… Is something went broken when I changed first Quality-patched firmware and then Official VS0E firmware? KPrope’s2 Bit Setting utility still works fine…

Welcome aboard :slight_smile:

It won’t be anything to do with your firmware or drive. If your using NForce drivers, then the later Liteon booktype utility will not find any drives. Also check your ASPI is working properly using Nero Infotool’s ASPI tab. It should say 4.60 is installed and working properly.

Yes, I have nForce2 Ultra 400 chipset motherboard. Asus A7N8X rev2.0 Deluxe and latest nForce2 unified drivers v5.10. And I have WinXP PRO SP2 so I haven’t istalled any ASPI drivers because WinXP didn’t need it so far.

Use Device Manager to Roll back your IDE driver. The NForce IDE drivers cause more problems than good and will stop many of the latest Liteon tools from working. If you use hibernate, your system will shut down a lot quicker as well. :wink:

ah, booktype v1.2.0 requires that ASPI 4.60 is installed? might this be the reason why it did not work on my 1633 BS0K? i have ASPI 4.71 (0002).

I don’t have installed ASPI, and BookType utility works OK (v1.0.6 and v1.2.0).
If I install ASPI 4.60, the BookType doesn’t work.

I’ve a nforce2 Ultra400 board (SOLTEK SL-75FRN2-L) with NVIDIA nforce2 ATA Controller (v2.5)…, and the system works OK. The burner is a Lite-On 812S US0N.

I 2nd this I have no aspi installed other than Nero’s and booktype 1.06 and 1.20 work fine with N-force 5.10 drivers on N-force 400 chipset. Oh 832s drive too. :slight_smile:

4.7’s API is different from 4.6’s. So it’s usually one or the other and not both. I have ASPI 4.6, and the tool works just fine.

Yeah… I used system restore feature at WinXP PRO, before I installed KProbe v2.4.2. KProbe installer seems to install ASPI Layer 4.72.1 driver during installing KProbe :frowning:

Now after systemrestore, Liteon booktype.exe working again.

yes, you are right, i installed 4.60 now, and booktype works again…

You sure? The only reason I have ASPI 4.6 on my system is because KP put it there.

I had a clean winxp sp2 system (last month), I installed nero, alcohol and KProbe 2.4.2 (software related to burning), and i finished with ASPI 4.71 (0002), so if neither nero nor alcohol put it, it should be kprobe…

Is it possible that some files are only contained in v4.60?
After 1st installing v4.60 and then upgrading to v4.71.2 afterwards, I get the following combination. :confused:


These files have the same date, so they should fit together. The 4.6 binaries are dated 1999.