LiteOn SOHW-1693S Downflashing?

vbimport

#1

Hello,

I have a LiteOn DVDRW SOHW-1693S and last night, I was having problems with some game backups (PS2) having very long load times, so I tried different media, then upgrading my firmware. It flashes successfully and all, but I’m having some problems now.

I went from the KS0A to the KS0B (DR16KS0B.zip) and now it seems my PS2 backups don’t even load at all, atleast the ones I have burned between updating my firmware last night and this moment.

It’s even the exact same media as my past backups (Memorex DVD+R @ 1x, also tried 2x & 4x), so there’s nothing wrong with those I don’t believe.

I am mainly wondering if it is possible to download the KS0B firmware back down to KS0A, and if you could help me that would be great, because I believe that’s the source of my problems…

Thanks.


#2

Gosh Use Teh Search Button Liek Zomg.


#3

Welcome to cdfreaks :slight_smile:

This might save you some time:
http://codeworks.cdfreaks.com/cgmirror/firmwares.html#SOHW-1693S

Use the KS0A firmware you see there. :wink:


#4

Ah, thank you very much. Downgrading as week speak, and I’ll repost/edit with my status.