Liteon SOHW-1673SU Problems

I have the SOHW-1673SU (Sorry, couldn’t find any threads relating to this) and all of a sudden, no media is read when I insert a blank or a burned DVD. Doesn’t matter if its a cd or dvd. It’s just like nothing is in there.

Can anyone help? Thanks!

Anyone? Please? Thank you.

Welcome to CDF’s

About the only thing you can do is put it in another pc and try it out. The all of a sudden thing probably means it’s toasted.

Thank you :slight_smile:

No problem. Have a good one :slight_smile: Let us know how it goes and post back.

I just downloaded some firmware and tried that…from codeguys. And when I run the program, it says:

No Match Drive Detected!

This utility is only for Liteon SOHW-1673S Drive

Detected Drives:

1-0-0-0-D: MATSHITADVD-RAM UJ-831S 1.40 (Which doesn’t work either and is a piece of junk)
2-0-0-0-E:
3-0-0-0-F:

For some reason, it’s not reading my LiteOn?!

I wish I had another computer to try and see if it worked there, but I don’t : /

Try cleaning the laser lens

So sorry to be a pain, but how do I do that?

Here’s a review. Don’t post questions in the other thread. Messes it up.

Sorry, i’m a noob. :doh: