LiteOn SOHW 1213S - Problem after Updating Firmware TSOJ

vbimport

#1

Hi!

I’ve read the forum as far back as possible to find a similar problem to mine - but can’t find this exact one.

Wasn’t having any problems with the drive but decided this morning to update the firmware from TSO8 to TSOJ. Burned a film on DVD with Nero as usual and watched it back on my DVD player/TV.

Here’s the problem. The drive will now not recognise any disc I insert - have tried data cd’s, music cd’s, data DVD’s and DVD video. It tells me to insert a disc when I click on the drive in explorer. Ran the Nero Test Drive and it recognises and reads a disc in the drive yet I can’t view it or open it with windows. Here’s the result of the Nero Info Tool:

Drive Information

Drive : LITE-ON DVDRW SOHW-1213S
Type : DVD±R/RW Recorder
Firmware Version : TS0J
Buffer Size : 2 MB
Date : 2005-11-25
Serial Number
Vendor Specific : 2005/11/25 11:40
Drive Letter : D:
Location : 1:0
Mechanism : Tray
Read Speed : 48 , 40 , 32 , 24 , 12 , 8 , 4 X
Write Speed : 48 , 40 , 32 , 24 , 16 , 8 X

Read CD Text : Yes
Return C2 Pointers : Yes
Read CD-R : Yes
Read CD-RW : Yes
Read DVD-ROM : Yes
Read DVD-RAM : No
Read DVD-R : Yes
Read DVD-RW : Yes
Read DVD-R DL : No
Read DVD+R : Yes
Read DVD+RW : Yes
Read DVD+R DL : Yes
Read BD-ROM : No
Read BD-R : No
Read BD-RE : No
Read HD DVD-ROM : No
Read HD DVD-R : No
Read HD DVD-RW : No
Read HD-BURN : No
Read Digital Audio : Yes
Read CD+G : Yes
Read VideoCD : Yes

Write CD-R : Yes
Write CD-RW : Yes
Write DVD-R : Yes
Write DVD-RW : Yes
Write DVD-R DL : No
Write DVD+R : Yes
Write DVD+RW : Yes
Write DVD+R DL : No
Write DVD-RAM : No
Write BD-R : No
Write BD-RE : No
Write HD DVD-R : No
Write HD DVD-RW : No
Write HD-BURN-R : No
Write HD-BURN-RW : No
Buffer Underrun Protection : Yes
Mount Rainier : No
SolidBurn : No
Modes : Packet, TAO, DAO, SAO, RAW SAO, RAW DAO, RAW SAO 16, RAW SAO 96, RAW DAO 16, RAW DAO 96

Region Protection Control : RPC II
Region : None
Changes User : 5
Changes Vendor : 4


The only thing I can see that might cause a problem is that the Region Code isn’t set? Any help/pointers would be REALLY appreciated!!

June
(ps or should I just go for the crossflash to a 1653s?)


#2

Hi & welcome!

The Region Code may have to be set for watching DVD-movies (or you can disable it with LtnRPC), but shouldn’t affect the other discs you’ve tried. Do I understand you correctly if you say Nero still works (you can burn discs), but Windows Explorer doesn’t?

You can find a whole collection of firmwares for this drive on the Codeguys site, even TS08 if you want to flash back to the way it was before the problem started. The best of the rest will be BYX5 and CS0T.

If you can’t get it to work again with another firmware flash, try uninstalling the IDE-channel in Device Manager (see here - first post, last paragraph). Also check your DMA-settings as described there.


#3

Thank you Cressida!

I took the plunge and went with CSOT - now discs play normally again. Weird one.

Just to do some test burns now and make sure that goes ok with this newest firmware!

Cheers
June


#4

hi i have the same drive and sorta the same problem, when i upgraded my firmware to tsoj, i sometimes can access the files and also i cannot burn now :a gwtmh how did you do it?Which one did you use?

hey you can flash back to older firmware?

thx


#5

shau, welcome to cdfreaks. :slight_smile:

Use the “CS0T - patched - crossflashing” firmware on my site (see my signature).

Yes you can flash back by using the 1213S firmware, also on my site. :wink:


#6

oh thanks that is so cool to flash back also, is it the csot crossflashing multi colored led one and not the fast burn one?

thx


#7

it’s not the fast burn one.


#8

okie dokie ill give that a try


#9

I have this same drive (SOHW-1213S) also and after updating the firmware to TSOJ the drive will not burn ANY dvds using nero. Nero reports the disc as “Illegal Disc” and then the burn process fails. The dvd is still blank.

I have tried the EEPROM utility to upgrade the drive but no luck.

MY PROBLEM IS NOW SOLVED. I USED http://codeguys.rpc1.org/firmwares/dvdrw/1653S.CS0T.patched-cf-mcled.rar .


#10

No luck on same drive here after trying the solution offered. Using Memorex 4x DVD-RW media.

Any suggestions?


#11

Well, went to Target and just switched them for +RW’s and it’s working fine.