LiteOn SmartWrite?

vbimport

#1

I came across a page for LiteOn’s SmartWrite utility, which is supposed to dynamically create write strategies for unknown discs - I was wondering if it might be of any use to me with the problems I’ve been having with MBI & MKM discs (Asus 24B3LT@iHAS424B)?

The link on C0deKing’s page is dead :frowning:

Thanks!


#2

Disclaimer: I could be totally wrong.

SmartWrite is better known to CDFreaks/MyCE as HyperTuning and Online HyperTuning. In at least some versions of ImgBurn (possibly the latest; I cannot check on my OS), it is referred to as such, and the SmartBurn utility (available from LiteOn’s global site, in the downloads section, under utilities) may still reference the functions as such.

Brief summary of those two:
HyperTuning creates a new strategy as best it can if forced on. For select media, it was always enabled as a part of the write strategy. 5 separate burn strategies are stored (possibly multiple for the same one), though occasionally it can get messed up (especially if you run across one or two bad discs in a bunch) and will need to be reset for immediate return to normal quality.

Online HyperTuning does NOT create a new strategy. Instead, it is (was?) akin to WOPC/AOPC/the quality checks other drives did during a burn (instead of smooth lines/curves, you have dips every so often–the drive checks the write quality).

In either case, you get either a “This helped”, “This had no effect”, or (in worst case) “This made things WORSE”.

All of this was true through at least the DH-20A4 series. I am not sure how things have been tweaked in the 7 or so new hardware releases since then.

What problems have you had with MBI & MKM discs?


#3

Ok, that helps. I do use ImgBurn, with those options enabled.

They’re blowing out with “Failed to Read Sector XXXXXXX - Reason: L-EC Uncorrectable Error” (DL discs - MBIPG101-R10-65 & MKM-001-00)

:frowning:


#4

And that’s during the burn process? Hmm, maybe the LiteOn is broken. Can you post a full burn log? (I’m not sure if you have a thread dedicated to the problem already or not.)


#5

No, not during the burn process, during Verification (with ImgBurn).


#6

This is a long shot, but I’m guessing trying to use CD-DVD Speed/ DiscSpeed / Opti Drive Control fails to properly read and/or quality scan the discs to completion, too?


#7

I honestly haven’t thought to try them. Was just going by the errors generated by ImgBurn (didn’t expect them to be inaccurate). I suppose if they are, then that’s something Lightning UK needs to look at.


#8

Nero CDSpeed v4.7.7.16 returned the following results for one of the MKM discs -
General Information
Drive: ATAPI iHAS424 B
Firmware: GL1A
Disc: DVD+R DL (MKM 001)
Selected speed: 8 X
PI errors
Maximum: 1399
Average: 13.83
Total: 338066
PI failures
Maximum: 316
Average: 0.04
Total: 8656
PO failures: n/a
Jitter: n/a
Scanning Statistics
Elapsed time: 14:56
Number of samples: 181445
Average scanning interval: 1.08 ECC
Glitches removed: 1

OptiDrive v1.5.1 returned the following results -

                 PIE          PIF

AVG 13.84 0.05
MAX 1394 196
Total 338388 9606

I’ve really no idea how those compare or rate.

The disc loads and plays, but will stop ~3/4th of the way through.

The MBI discs would not test with either program, but were recognized.

Nero CD-DVD Speed: Disc Info
Basic Information
Disc type: : DVD+R DL
Book Type : DVD+R DL
Manufacturer: : unknown
MID : MBIPG101 R10 065 (41h)
Write speeds: : 4 X - 6 X - 8 X
Blank Capacity : n/a
Extended Information
Layers : 2
Layer break : 3.98 GB
Write strategies : n/a
Disc Status : Open
Raw Data
Physical Format Information (00h)
0000 - E1 0F 32 10 00 03 00 00 00 FC FF FF 00 22 D7 FF - …2…"…
0010 - 00 00 03 4D 42 49 50 47 31 30 31 52 31 30 41 40 - …MBIPG101R10A@
0020 - 25 25 37 10 00 2C 6C 00 2C 6C 20 1F 0C 0C 14 14 - %%7…,l.,l…
0030 - 02 01 01 20 00 20 1F 0C 0C 14 14 02 01 01 20 00 - …


#9

Referencing this post: http://club.myce.com/f92/changing-dvda-r-write-strategies-results-thread-124899/index16.html#post2604236

…and trying to keep the problem contained in one thread…

You probably have bad discs or a bad drive. Your drive supports both disc models, and though it’s possible the firmware support could be increased, it should already be more than good enough to burn both, including the MBI. (Yes, the MBI should be supported, since they are given 8x support).

Without seeing the actual graph (sorry, I failed to mention that attaching a shot of the graph would help others analyze what’s going on. :bigsmile:), I can tell you the MKM 001 burn went far out of specification. A PIF max of 4 when scanned on drives like the LiteOn is usually considered good; 10 would be bad. You hit a PIF max of >300 and 200. That’s really not good.

There’s no way to say at what point on the discs you have the problems, or if the problem happens in the same point/happens the same way on all the burns. But it’s clearly there.

Maybe, if you will, inspect the underside of the burned discs, and see if you see any unexpected specks or other imperfections. There may be perfect “rings” visible from the burner tweaking laser parameters during the burn, which are fine.

MBI media is known for being good when it’s good, and for being bad when it’s bad. But the MKM/MCC/Verbatim media is known to be good in many many cases, which makes me think you just have a bad drive.


#10

Sorry, about the diff posts - responding where it seems appropriate :slight_smile:

ASUS has offered to RMA the drive, so I may end up doing that after all - would make the 2nd bad drive of this model I got from the same vendor (no, not NwEg, lol) - got it on sale and have wasted more money than I would have getting it elsewhere :frowning:

The underside of the discs look just fine, no damage, scratches or the like.

Do you have an opinion on switching/adding the writing strategies? Substituting the RICOH for the MBI? Not sure about the MKM.

Thanks much.


#11

No biggie about the spread out posts. It’s just easier to help you pinpoint a problem this way, since the posts all come back to this main issue of poor DL media performance. :slight_smile:

You can try swapping the MBI with the Ricoh, but outside of that, I have little suggestion. If you wanted to be daring, you could try MKM 003 for either the MBI or MKM 001, since you’ve got little else to lose.

This assumes MediaCodeSpeedEdit supports the DH-24AB (iHASx24 B) drives.


#12

I don’t even know if MCSE is still supported :frowning: Hopefully one of the experts will respond in the other thread. I’m still not quite clear on HOW to do it. I HAVE been able to open the BIN file for the current GL1A firmware, but I don’t know how to go about doing the Addition/Substitution.

Since the RICOHs burn 99.9% fine, and they are made by the same manufacturer, in the same plants, with the same materials, it would seem that that would be the most logical.

I have tried to load every firmware I have for all 3 drives (Plex, LO, & Asus) and neither the EXEs nor the BIN files will load in OmniPatcher - which is apparently what I need for “re-assignment”. MCSE does load the files, but i don’t know that I can do the re-assignment in it.

Thanks for any help :slight_smile:


#13

OmniPatcher doesn’t work for anything newer than (essentially) the 1st generation 16x burners. Meaning none of the 18x, 20x, 22x, or 24x drives are supported, and the later 16x drives are not supported. There will be no further updates for the tool.

I don’t know about MCSE. Just the simple fact that the media code list extraction has a lot of formatting issues means the firmware isn’t fully supported. Whether or not MCSE will be updated further is unknown.

I really wouldn’t rely much on strategy swapping to help much.

Ricoh DL media is made by FTI, MBI, and Ritek. So it’s possible that the Ricoh strategy could work for the in-house DL from all 3. The Ricoh strategy working BETTER than the stock strategies would be quite unexpected for such mature drives.

Similarly, MKM media is made by FTI and MBI (and by MKM itself, unlike most of Ricoh’s media). The MKM strategy is usually the one people use to try to solve problems, but since you’re having trouble with actual MKM media, I’d have little hope there, too.


#14

A further reply (from reading over some of your other posts):

If you are trying to use Kodak-branded media: Kodak is no longer known for choosing the highest quality media. You could have B-grade/C-grade/F-grade media on your hands that deserves to be replaced. You may have to replace it with Verbatim-branded media, which usually helps avoid any problems whatsoever.

Since you have seen RICOHJPN D01 and had it function fine, you might be thinking that strategy swapping would help. Well, Ricoh D01 has suffered from many of the same issues you’re having. It’s kind of the luck of the draw on whether the quality is good or bad under some of these brands. That’s why I think swapping strategies will not work as well as hoped.

I also notice that you have tried a few of the same drive (which you pointed out above). Maybe try a different model of drive, if possible. Though the LiteOn should perform fairly well (heck, it wrote to the Ricoh!), it could be that you would have better luck with an Optiarc.

You’ll notice others have issues with MBI’s DL media, too:

And more recently, member jadburner had a batch that had a characteristic spike of errors at the same spot across a number of discs in a number of drives:

This, again, isn’t to say that MBI’s media is crud, but it is easy to get bad discs under good brand names.
And other good manufacturers, like FTI, can be affected with their own media:

…Just pointing out the wide range of issues that could possibly plague you, that are more related to media than to the drive writing them not being equipped to write them. It may be more prudent to wait until you can try new hardware and new media so you don’t waste time trying to tweak the software end of things.


#15

I’ll see if I can grab the HP 1270i from BB today (it’s literally twice the price of the LO or Asus, and a 1/3rd more than the Plex, but I seemed to have great results with it when I had it temporarily. I guess better more for a good burner than less for a bad one. And I’ll RMA the Asus.