Liteon LVW5005 Upgrade Failures

vbimport

#1

I’ve just joined the club of disappointed Liteon users who can’t get their LVW5005’s to accept upgrades.

Does anyone know of any tricks or special way you have to make a face to get these things to accept upgrades??? Liteon Tech Support emailed me a “guaranteed to work” 1091 upgrade & directions to install it. I religiously followed those installation instructions; trying numerous times/numerous ways to make a CD-R (using Nero6 & finalizing the CD) that would do the upgrade. All I ever get is the usual “loading” & “data disc” dis-function; but never the required installation screen.

10 (plus) coasters later, I’m convinced that Liteon probably has some problems they’re not willing to admit to.

I’d truly love to hear from Liteon LVW5005 owners about their experiences. Is the installation of Liteon upgrades really like “russian roulette” or “the lottery”??? Or am I missing something?

Best regards


#2

What you are describing sounds like an attempt to program the player with firmware marked for a different hardware configuration. The “failures” described here seem like hardware issues; i.e. faulty flash ROM chips that fail while being programmed.


#3

Hi Schuster, Thanks for the reply.

The firmware was emailed to me by Liteon Tech Support in response to my request for assistance with this issue. Additionally, there are other members of this forum who claim they have used this very same version to upgrade their Liteon 5005’s.


#4

I understand. However, I have read accounts of Lite-On Tech support emailing firmware that was clearly flagged for different hardware than the owner had - and, not surprisingly, it did not work.

Remember also that there are different hardware versions in each continent; for instance in North America there are models with serial numbers beginning with 0102 and 0104 and they require different firmware. Does the firmware emailed to you by tech support match your electronic serial number in this way?


#5

Hi Schuster, Please clarify this serial numbering. My first 5005A (USA), was October 2004 production, had the S/N 602441042551. I returned it to Costco for an August 2004 with the S/N 60143200533. Maybe I’m missing something, but neither one has S/N’s starting with 0102 or 0104.

With the August unit, I tried firmware LNFB2063.D00 which is said to flash & hack this vintage. I also named it “Mediatek” on the CD label per Liteons published instructions. This didn’t work either.


#6

Hi…I use CD re-writable to flash firmware and neno to burn it…it might help!


#7

Hi Pong, Thanks much for the reply. I’ll try a CD-RW and Nero to burn it. Did you follow Liteons instructions for setup & burning with Nero? Did you set Nero to finalize the burned disk?

What is the production month/year of your machine? What firmware did you use?

I wonder if the burner used for the firmware can make a difference? I use an HP 200I internal drive.


#8

Just tried a CD-RW. It doesn’t work here. Gets rejected the same as all the others.


#9

The serial number he is refering to appears at the top right of the setup screen.
You say you tried the firmware LNFB2063.D00. That is not the correct firmware for a US model. The US firmware has a “A” where the “B” is and a “1” where the “2” is. Also that appears to be an older firmware.

I just upgraded mine using the hacked firmware LNFA1091.ESU and had no problems.


#10

Hi Terminalmind, Thanks for the reply. It’s appreciated.

Now that the location of the S/N on the Setup screen was pointed out to me; I was able to find it. It was unreadable until I reset brightness & contrast on the TV so it could be seen.

With the correct S/N in hand, I was able to go to Liteon website & download the appropriate System (firmware) update. The version on my machine is 0086 (actually 1086?) and the correct update given there was LNFA1091.ESU.0102.114x.rar. Again, I carefully followed all instructions, burned the disc, etc. but “no joy”. The Liteon wouldn’t mount the disk so the update image isn’t being recognized.

This is the same thing that has been happening to me for some 25 coasters now - regardless of the update versions.

It almost seems to me that there may be some obscure thing that is set wrong on my burner. Otherwise, there doesn’t seem to be any logical reason why the disk shouldn’t be recognized.

Come on you CD & drive wizards, put your thinking caps on & help me to find a solution to this very frustrating dilemna.


#11

Are you following the directions posted at the liteon website?
Here is the link http://www.liteonit.com/DC/english/download/udcp.htm

Try setting the burn speed to its lowest setting.


#12

After you burn the CD, look at its contents. You should see a single file in the root directory named LNFA1091.ESU

If you do not see a single file with that name in the root directory of the CD, you have not followed the proper procedure for creating the disc.

Remember that the .RAR file is a compressed archive which must be unpacked
to create the firmware file, LNFA1091.ESU. You must use UNRAR or similar
utility to do this. The file you downloaded cannot be used “as is” - it must be unpacked first.

You then need to make a DATA CD in ISO-9660 format containing that one file - LNFA1091.ESU. This is NOT the same as burning a disc from an .ISO fiile. (Sorry if you alreay know this, but it must be eliminated as a potential source of error).

If you do see that file in the root, and the 5005 will not load it, do a binary compare with the original source on your hard drive. They should be identical. If the 5005 still won’t load it, try burning using a different brand of blank, and burn at a slow speed (4X).

If the 5005 still won’t recognize it, I’m out of ideas. Either the firmware is not the proper one for your machine, or the machine is having trouble reading discs.


#13

Hi…The recorder manuf. oct 04,s/n 602442000196,F:LNFA1090,D:B203, HI-POT OK … these are the information on the box.I’m update the latest firmware from liteOn web site[LNFA1091.ESU.0102.184x(1,865kb)] I use WinRAR to open it…drag and drop to Nero and click burn…put cd in recorder the update begin…it change the number in setup menu from 0090 to 0091…I’m also update the drive[LNFA1000.E30.0102.184x(252kb)]…it change from B203 to B205…then I download the edited file from ‘Intersys’ [LNFA1091.ESU (1,863kb)] flash it to the recorder again…the number change again from 003 to 013,DONE :slight_smile:


#14

Hope these help, its the Nero 6 Burnng Rom settings I used yesterday to burn my edited Pal firmware: (al assuming you have extracted the rar or zip to get the file ending.esu, type ESU file):

With apologies for stating the obvious at times but its clear that a lot of people have problems burning!

New Compilation - CD - CD-rom (iso)
click ISO tab on dialogue box - should show - mode 1; iso 9660 only, max of 31 chars (level 2), iso 9660 (standard iso cd-rom). Then ensure all 4 of the entries in the Relax Restrictions section are deselected
Click Burn tab and ensure write and finalise cd are selected.

click new, add your file so that in the left hand column (under) ISO1 it says New, then in the next column you drag your file .esu and then burn, ideally to cdrw, speed doesnt seem to be a problem, I burnt at 4x

good luck


#15

After downloading and then unpacking the firmware I just copied it to disk and made sure it was closed and it worked perfectly the first time . I then knowing that it would update modified it for the macrovision and three hour recording mode operation and it also worked fine . After reading the above posts you may want to try some other CD’s possibly with music and test to see if your recorder is working correctly . The above information from other posts all seem valid to get you working unless you have a recorder problem .
LNFA1091.ESU Is the correct file for the united states region .


#16

Thanks for all of the ideas. Since we may be starting to get somewhere here, let me respond to some of them

[Are you following the directions posted at the liteon website?
Here is the link http://www.liteonit.com/DC/english/download/udcp.htm Try setting the burn speed to its lowest setting.]

I’m following those instruction precisely - but I’ll try again. As I recall, burn speed was 4X but I’ll try 1X.

I am definitely extracting the firmware using either rar or zip; depending on how it was compressed. When I open the CD-ROM in my drive, I see only one firmware file “LNFA1091.ESU.0102.1” - no folders,etc.

From memory, I believe that I pretty much followed the instructions in DrMabuse’s post. Burn speed was 4x on the last try. I’ll try again using different CD-R’s, slow burn speed and use of your setup notes as a checklist this time. Additionally, I tried playback of some audio CD’s on the Liteon as well as my PC burner.

I’m not very knowledgeable about hex editors or comparators. However my son is so I’ll ask him to have a look.


#17

Well that’s definitely not right.

You should see one file exactly with this file name.

LNFA1091.ESU

It looks like maybe when it unpacked it from the rar somehow it got the wrong file name. try renaming it to exactly what I have above before burning it.

Also on the disk it should be 1,894 KB as reported by windows.


#18

fyi i use cdr/rw or dvdrw they work for me when doing fw upgrades


#19

Brian, The revised 1091 file is the latest I downloaded from Liteon website. I also had a copy of the 1091 which was downloaded exactly as you showed it. Both were 1.89Mb. Tried them, but no joy! Also tried 2.4x burning, DVD+RW & CD-RW - nothing there as well.

Having noticed differences in the icons shown on the Liteon website instructions as well as my PC & Disks, Im starting to wonder if perhaps this is a file association issue. Doesn’t make sense that so many people are updating without any problem & I can’t even get the disk to mount.

Other than the basics, I don’t understand much about file associations. I would very much appreciate some one checking to see how ESU files are associated on their PC’s. I looked on the internet, but haven’t found any infomration on this type of file extension. Or, if this is a non-issue, please tell me so as well.


#20

Are you using WinRaR to unpack the rar file?
Like brianp6621 said, after upacking the rar file you should have a file named “LNFA1091.ESU”.
What Operating System are you using? I am using Win XP and after upacking the file the size is 1.84MB(1894KB)

Have you tried downloading the hacked version of LNFA1091.ESU that intersys posted in the Liteon 5005 thread? It is a .zip file instead of a .rar file.