Liteon LVW-5045, Randomly Switching Source

Hi all,

My LVW-5045 DVD recorder is about 2 years old and in the last 6 months it has started to turn itself on randomly. I have been watching it to see what its doing to try and determine WHY its doing this and this is what is happening:

  • Machine is either ON or OFF
  • Machine suddenly changes SOURCE from SCART to DV
  • If machine was OFF, it turns itself ON, changes source to DV and ejects the tray
  • If machine was ON, it just changes source to DV and the screen goes blank in the middle of whatever I was watching

I never intentionally use DV as a source, it is always SCART, so I do not know why it is always changing the source.

At first I thought there was some old timer record left in it and it was trying to record something, so I went in an manually deleted all the out of date timer records. It has not resolved the problem.

Any ideas?

Poppy

Hi poppy_uk, try reloading the firmware. You might want to bring the 5045 to the “put in cd” mode for the firmware update by plugging the 5045 into a power bar with switch off then turn plug strip on while holding the 5045’s stop button and continue to hold stop till display shows PUT IN CD, release stop button, drive tray will open, put CD in tray and press close button. Drive should spin up and display shows F-UP 00XX, firmware is updating DO NOT POWER OFF AT THIS TIME. Update will check drive and display will show D-UP 00 if drive needs update the 00 will increase to 99 if not the display will show DONE and the drive tray will open, remove CD and leave tray open, turn plug strip off for about 30 seconds and then back on. The 5045 should display HELLO, the drive tray will close and the display will show BYE and power off, display will have clock 12:00 and you can now power the 5045 up by the front on/off switch, all should be good.

This is how I revived 5 5007s that people sold as is for parts only, the 5007 would be stuck in power up/power down loop. The 5007 takes a while to shut down and if you unplug or power failure just before the system was completly shut down, it would go into this loop mode. I just wanted one to work, but manage to get all 5 to work :smiley: , worked also with my ILO HD04 which I was pressing too many buttons and it went to “put in cd” mode so I just inserted my firmware back in it and everything was fine. Maybe it will clean up that bizzare switching problem of your 5045.

Good luck, keep us informed on your progress.

PS. the recordings on the hardrive will still be intact after this process.

Thanks Canuck, Gonna give this a go this afternoon.

The other thing I was thinking about is that this problem only started when I got my new satellite box. The SKY satellite box is connected to the DVD recorder via the SCART cable. I’ve had a SKY box connected to it in the past, but they are constantly changing the boxes and this new box is a totally different model from the one I had connected in the past.

I wondered if the connection to the DVD recorder is being interrupted and this is why it switches from SCART to DV - like its losing the SCART signal. Obviously it shouldn’t be, this is digital signal - but getting this new SKY box is the only thing I have changed in the operation of the unit. Might be something as daft as a dodgy SCART cable.

Will let you know how I get on!

Poppy

Canuck I tried to follow your instructions but when I held the STOP button while turning back on the powercord to the unit, nothing happened. It just turned the unit on as normal - no “put in cd” message appeared. I tried several times.

By STOP button you mean the STOP button as if I was stopping a DVD from playing ya?

In all my fiddling about today I downloaded and updated the firmware on the unit, so maybe that will have some magical effect. As the problem was occurring several times an hour while I watch TV, it shouldn’t take long to see if that alone had any effect.

Poppy

That would be the stop button on the unit not the one on the remote. I would definitely try loading the firmware just to see if it would clean it up. I’ll try the power and stop later today on my ILO HD04 (a baby 5045 at 80 GB) and report back, I’m thinking that I need to also hold the power and stop then plug in to the outlet, might need one more hand to assist !!! I’ll let you know.

Yes, I meant the stop button on the unit, not the remote control - although in desperation I tried both!

The verdict is in on the firmware update - no it hasn’t solved the problem, only now… when it turns on, ejects the tray, and switches source, the display on the unit reads “CH 2” instead of the old “D - 1 IN”. And now the screen goes to fuzzy static rather than the blank grey screen it used to go to.

On top of that I just switched the unit on via the remote control and after a few seconds it automatically went to the Timer Record page and just sat there… until I hit EXIT.

And now after a few more minutes the ‘display’ bar at the top of the screen has just automatically appeared.

It is as if I’m sitting here hitting buttons on the remote control! Do you think there is a poltergeist living in the remote control!!!???

Poppy

Hmm… and now it just went to the “Easy Guider” page, sat there for a moment and then the unit switched itself off.

I’m thinking the firmware update has done more harm than good.

By the way I have changed the batteries in the remote just in case there was something weird going on there with a degraded signal.

Poppy

At this point I would reburn the firmware disc just to be satisfied that I tried a freshly burnt disc. Some really weird symptoms you’ve got. The static has been known to maybe be caused by electric/electronic interference or noise by having electrical and A/V cords being too close/overlapping together. I don’t think that it would affect the switching issue though.

You’ve checked the buttons on the remote to verify that none of them are pressed in and stuck, once pressed in, they comes back out, these units do not have a great “pending file” attribute to them, if a button is stuck, it might be sending constant signals confusing the unit, usually the unit would freeze, something to look into.

hiya, by static, I just meant a TV screen that has no signal going to it. Sorry for the confusion.

Since my last post the machine has just been randomly turning itself on/off at pretty regular intervals. I was sitting at the computer for a long while not paying attention to it and when I turned back it had been recording for the last 25 minutes. So it seems that it is just randomly implementing any of its functions.

Unfortunately I have moved 5 times since I bought this machine and have no clue where the original disc is that came with the unit, so can’t even try loading up the original firmware. I will try re-downloading and burning the firmware update and see if it has any effect.

Anyway to reinstate the original firmware without having the disc? Longshot I know…

Poppy

I have eliminated the remote as a source of problem by removing the batteries from it. While the batteries were out the random problems continued.

It just seems to be cycling through all the functions now - has been into the Browser, Guider, Timer Record, Disc Tools plus turning itself on & off and randomly ejecting the tray. Oddly, it doesn’t seem to switching SOURCE anymore, which is what the original problem was - but that could just be that I haven’t seen it happen. I can’t keep up with it now.

I’m thinking running over it with my car might improve things…

Poppy

ok - new theory…

In everything that has been happening, it has been giving the appearance that someone is sitting there playing with the remote control accessing functions. But I’ve eliminated that as a possibility with my actual remote so assumed that meant there was a problem with the unit itself.

These problems started occurring at the same time as I bought a new television. Can I assume from your name that you are Canadian? I’ll presume you are Canadian (I’m Canadian too! just living in the UK!) and aren’t overly familiar with how we hook things up over here… and apologise if you know all this already…

Most people over here don’t have cable. TV is primarily provided either by antenna (just the 5 domestic channels) or fixed satellite mini-dish (like cable, you get a ‘package’ of channels, not like satellite dishes of old that could be moved to pick up anything). Cable is only available in very limited areas and there is something else called Freeview too - which isn’t important at the moment! Anyway, I have satellite and to use it you need to connect a ‘box’ to the TV. Similar to the cable boxes in Canada. You need it to take the signal from the dish to the TV.

This past year I bought a new TV, and when I did that I put the old TV up in the bedroom. There are only two ways to split the satellite signal - either get a second line brought in from the dish and a second box hooked up to the second TV, and pay for a second subscription… this method lets you view different channels on the two TVs at the same time… or you can buy a small transmitter that you hook up as follows - 1) to the satellite box and 2) to the second TV - and this allows you to control the SKY box from another room and transmit the satellite signal to the second TV.

This second method costs only the cost of the transmitting unit, which is like £30, but the disadvantage is that since there is only one actual SKY box, both TVs have to be watching the same channel at the same time. As I live alone and won’t ever need to be watching two different TVs on different floors on different channels I wasn’t about to pay the installation and subscription charges to have a second SKY box set up.

I tell you all this because I wonder now if it is the transmitting unit that is somehow screwing up the DVD recorder. The transmitter is designed to work with any AV equipment - not just a satellite box. So I could hook it to the DVD player and stick a DVD in and watch that upstairs and be able to control the DVD player… if I wanted to.

In my case it is hooked up to the SKY box only - BUT I’m starting to wonder if it is throwing around some interference that the DVD Recorder is tapped into. I know for a fact that no one in MY house is pushing buttons on a remote control, but that is not to say someone next door isn’t doing something. The transmitter unit is subject to interference the same way old portal telephones were… if you know what I mean… it has an antenna on the transmitter and another antenna on the receiver upstairs and there CAN be interference. Sometimes I get interference from the street and can’t get a strong enough signal upstairs to watch TV up there - so I know it is tempermental.

So my question is - because I don’t know AV equipment that well - can the proximity of the transmitter to the DVD Recorder be causing this? I just have my stereo/TV stuff stacked so the distance of the DVD Recorder from the transmitter is minimal. Only a few inches. BUT it is the transmitter - NOT the receiver. What I’m thinking is that the signal from the transmitter is going out and somehow being picked up and misinterpretted by the DVD Recorder - causing it to act on one of its functions.

Does that sound like something that could happen? Keep in mind ALL this equipment is hooked up to each other via the SCART cables (which is the primary way to hook up TV equip over here). So the satellite signal comes in via coax cable to the SKY box, then the SKY box is hooked up to the DVD Recorder via SCART, and the SKY box is also hooked up to the transmitter via a second SCART cable. Then the DVD Recorder is hooked to the TV via SCART.

The way SCART is meant to work is that all the units connected in the loop theorectically can talk to each other. The way it works in reality is that you can spend all day trying to get the loop right on the SCART cables to find a solution that sends the satellite signal to all the places you meant it to go - and there is often more than one solution! So this further lends to my theory that the transmitter (which is in this loop of SCART cables with the DVD Recorder) could be talking to it… if not via the antenna, then via the SCART cable.

What you think? Possible? If so, it is annoying because it means I’m stuck with the problem as long as I use the transmitter, but at least it’ll stop me from running over the DVD Recorder with my car! Do you think there might be a safe proximity I could put them apart? Or does it not matter because of the SCART loop?

Poppy

Yeah, made it home, canuck all the way and one big YES that the transmitter might be sending compatible frequences and the recorder is picking up on it. I would try to shut the power off on the transmitter for troubleshooting. I have two ILO HD04s side-by-side and I bent a strip (1.5 inch wide by about 7 inches long) of metal in a “L” shape, did a Red Green and covered it up with duct tape !!! I found the sensor eye and I cover it with the “L”, the long end (about 5 inches) sits on the top while the short end (2 inches, give or take, you need to measure for this part for the bend) hangs over the top and covers the eye so I can use my remote without interfering with the other recorder, I just move the “L” form one unit to the other dependant on the need.

If you find that it’s your transmitter that is causing the issues, you might want to find the sensor eye, it should be to the far right and fashion yourself an “L”, don’t forget the duct tape, get some canadiana going up there !!!

I just tried to do the “put in CD” command on my hardrive recorder and it didn’t work for me neither. I guess it only works with the 5007 (even maybe the other Liteon single drives) even tried holding power (thumb), stop (pen in mouth !!!) and flipped the power bar on, I looked silly and on top of that it didn’t work.

For firmware, if your model is the older 5045, not the gdl or ghc, here’s a site that you can downloaded from.

http://www.ss3f.com/ilo/5045/index.htm

Of course, use the UK version, this is the hacked version, it will render the older 5045 Macrovision free. The program was develop for the US models and it also drops the region number by one (from region 1 to region 0 meaning region free) because yours is a UK model, it will drop it from region 2 to region 1, so you’ll need to make it region free manually by going to setup, scroll down and sit on EXIT, press 2960 on the remote and the hidden region menu pops up, then you can set it to region free.

I’ve got a good feeling it could be that transmitter of yours.

ok - update…

Last night I removed the scart cables from the DVD Recorder so that it was no longer hooked into the other units. I also moved it in the AV stack so it was further away from the transmitter unit.

As the DVD Recorder was no longer connected to the TV, I couldn’t see if it was still cycling through the various functions, but I could see if it was turning itself on/off and ejecting the tray etc. It seemed to do nothing for the remainder of the time I was up last night - this was a couple of hours.

I got hopeful that I’d sussed the issue - but then today about an hour into watching TV it suddenly ejected the tray. Then in the next half hour it has pulled in the tray, switched source, ejected the tray again, and started recording on the hard drive.

So it would appear that if there is signal interference than it isn’t coming through the scart cables as it is still disconnected.

I had already made the unit region free by the way - and when I updated the firmware yesterday I re-did the 2960 thing. I thought perhaps maybe that is why it suddenly went haywire, so I reloaded the firmware update and DIDN’T put in the region free thing this time. Obviously as it has started acting up again, that wasn’t an issue.

It is the older 5045, so I’m gonna have a look at the link you included… What is Macrovision Free?

No Red Green here, and in fact it is only in the last few months that some retro channel has started showing MacGyver… so all my references to fixing things with duct tape, paper clips and chewing gum have fallen on blank faces for the last 8 years. Pour souls.

Poppy

Have now loaded the firmware from your link. Have unit plugged back into TV via scart, so gonna sit and watch and see what happens. Next step is to disconnect the transmitter - but gonna wait to see if symptoms reappear first with revised software. Can only eliminate one thing at a time to determine which is causing the problem!

Poppy

I doubt that it’s the firmware at this point, I really think it’s the transmitter. I had a VCR that would start up and acting weird and very often at the same time of day, figured it out, the actual sunlight, when the conditions where right, that was weird, I just added some shades to the window and it cleared up !!! I was going to suggest that but when you mention the transmitter, I think that would be more likely the reason.

Macrovision (AKA MV) is a copy-protection system, it is used to encrypted tapes and dvds to protect them from being copied. When trying to record commercial tapes and dvds or even some Pay-per-View events on cable boxes, the recorder will sense the Macrovision signal and stop recording and a message will come up and say something like" Can’t record, copy-protected".

Users started to experience this copy-protection was turning on even when trying to record their own homemade VHS tapes, if tapes where in poor condition, the MV would turn on and stop recording. A user developped a program (ILO/Liteon Smart hacker) to turn off the MV allowing tapes to be recorded, it was found that it also ignores the signal from a dvd player and cable box protected content. When units are upgraded with this version of the firmware, the output is also MV free. So if you upgraded with the hacked version and you can get it to stop acting weird, give it a test with a commercial dvd of yours using a dvd player and copying in real time, it dosen’t upload from the drive to the HDD.

This program was developped for the ILO model to add the 3-hour mode and make it region-free, eventually the MV was found and turned off and as ILO is a Liteon-based clone, the program also works on older Liteon units, Liteon caught on and changed the address of the MV on the newer models’ firmware and now it doesn’t work for those newer models.

These older models (ILO/Liteon) can also be easily repaired/upgraded. My ILO HD04s which are a dumbed-down 5045 (80 GB, +R/RW only and no LP mode), and were assembled with poor drives are now running on PC replacement drives and also larger HDDs (2 at 250GB, 1 at 200GB, 1 at 160GB).

Yes I’ve encountered the copy-protect thing in the past when trying to record pay-per-view movies off the telly. I’ve never been serious about recording stuff, so I never looked into doing anything about it.

When I first got the machine I copied a few old VHS that were in really bad shape and replacements couldn’t be bought on DVD as they didn’t exist, but other than that the machine was bought just to record TV shows when I couldn’t be home. I’d had a Panasonic model that didn’t have a hard drive (bought for a small fortune before hard drive models were readily available!) that packed it in and after paying once to have it repaired, when it went bonkers the second time I pitched it and bought the Liteon.

Anyway - since putting in the hacked firmware the only thing that has happened that I have noticed is that twice the display bar came up showing the symbol that appears when you push a button on the remote at a time when it can’t be used. You know, the circle with a line through it. Will keep an eye on it today and see what’s what. In any case, yesterday it was throwing up bogus functions every couple of minutes, so it is at least improved.

I wish I could just unplug it when I’m not using it (which isn’t very often anymore) and then the bogus functions wouldn’t bother me - but as the SKY box is routed through it before the signal goes to the TV, if I unplug it I lose the satellite signal. It’s too much work to fuss about with disconnecting and reconnecting scart cables all the time to put the signal direct to the TV when not using the DVD Recorder.

Will keep you updated!

Poppy

Moving it away from the transmitter seems to be the key, I don’t think the firmware cleaned it up, if the unit was in direct sunlight before you moved it, it might have been like what I was saying about my VCR problem, another issue to rule out I guess.

No sunlight I’m afraid, so not the issue. This is England! When is there ever sun!!?? :wink:

This afternoon I had a couple random things happen, but only a couple. Since then I have moved the transmitter as far away from the unit as possible, with solid stuff in between to restrict the signal. The transmitter & receiver also have switches on them to toggle between 3 different frequencies if you are getting interference from a neighbour - so I have changed the frequency. Just gonna see now how it goes.

Thanks very much for all your help! Got me thinking about Canada today and all I can think of is Cheez Whiz, KD, Alphabits, Eggos, Toaster Strudles, Chef Boyardee, Veggie Thins, Campbells Chicken Noodle Soup, Vachon cakes… ah the list of pre-packaged food I can’t get over here is endless… and depressing…!

Poppy

quick update - since I last posted here I have not had one instance of the DVD Recorder acting strangely. I haven’t been home a lot, but to go for a couple days and not come home to find it ON with the tray ejected is a vast improvement. I’m actually going to try and record something tonight. So fingers crossed!

Poppy