LiteOn LH18A1H Lightscribe errors

vbimport

#1

Hello everyone

I bought a LiteOn LH-18A1H this week to replace my old HP640c drive, which had died. It works well (though Lightscribe is slower than my old drive) and from a “using it” point of view, no problems; but whenever I use Lightscribe to label a disc, I find dozens of Event 51 errors afterwards in Windows XP Event Viewer.

As an example, I Lightscribed a simple label taking 12 minutes this afternoon at 15:37pm. Between 15:37:57 and 15:38:12 (15 seconds) Event Viewer shows 74 Event 51 errors. I did another at 18:16 that took 8 minutes; this time I had 75 Error 51’s in the 20 seconds between 18:16:30 and 18:16:50! I gather these errors aren’t serious (XP Help and Support says it’s IO_WARNING_PAGING_FAILURE) but I never had them with the old drive (also made by LiteOn, I think) and would like to stop Event Viewer’s log filling up with them if I can!

I wondered if it may be connected to the fact that the drive is shown in Device Manager as using UDMA 2 rather than UDMA 4. I bought a new 80-conductor cable and reinstalled both the drive and the controller secondary channel (where it is the only drive and set as Master) but it still shows as UDMA 2. My computer is 5 years old but does “know” about the higher rates, as my hard disk on the primary channel is shown as using UDMA 5. Also My Computer shows the LiteOn as a DVD-Ram Drive, though it’s correct in Device Manager.

I don’t seem to get any error messages when actually burning a disk, only when Lightscribing begins, and I’m puzzled as to what file it is trying to access. Thanks to this forum, I found a firmware update and flashed my drive from HL05 to HL06, but it made no difference and gave me the 75-error example above. The source of the warnings is “cdrom”, which I think is cdrom.sys/part of Windows? I can’t find any later Windows driver version than the one I have, 5.1.25.35.0.

Has anyone else had this and anyone got any ideas? And also (veering a little off the subject) did the problem with the 18A1H speed locking at 6x after Lightscribing a DVD ever get solved? I read about it this afternoon while browsing the forum and was slightly alarmed (!) I don’t have any DVD media to hand to see if I have the same trouble. I’ve only had the drive fitted 2 days and am wondering if I should return it now. . .

My system is a Dell Dimension 4300, Pentium 4 1.70GHz with 512MB Ram running Windows XP Pro Service Pack 2, fully patched. Thanks guys, I’d be very grateful for help or advice.


Nowl


#2
  • Thread moved from the LiteOn Forum * :slight_smile:

#3

Thanks for moving my post, Arachne.

I think I know now what is happening. I tried a very simple label, keeping an eye on Event Viewer all the while.

I got an Event 51 error as soon as I put the upside-down disk in the drive. Then in the first 17 seconds after I started the burn, I got a further 66 warnings. So it seems as if the drive at first “thinks” the LS is an ordinary disk; it tries to read it, fails because the disk is upside-down and generates these errors. Once the LS software kicks in and the actual burning starts, it works fine.

Please guys, can anyone confirm they also see this on Windows XP Pro? I just don’t know if I’ve got a faulty drive or if this is normal behaviour for this model, and if I need to return the unit I’ve got to do it within the next few days. I’d be so grateful for any help or comments.


Nowl