LIteOn LH-20A1P not working properly in Xp Normal mode

Hi :eek: ,

I have a LiteOn LH-20A1P DVD Writer. The problem is that it hangs and freezes up when I try to read a dvd. The default AutoRun feature of XP comes up and shows the drive with the Main Folders. But when I try clicking/Double Clicking/Right Clicking the folders , the system becomes sluggish and hangs. The weird part is that it works PERFECT in safe mode. Everything gets read , and I can write DVD’s without a problem. At first, I thought it was a problem with the startup items or services so I disabled the startup items and All Non Microsoft services. But the problem doesn’t seem to go.

OS : Xp , sp2
Anti Virus : Kaspersky
Firewall : Outpost

I have 2 drives on this IDE cable. The DVD is on Cable Select and the other one (LG CD ROM) is set as Master.

Since , it seems to be working flawlessly in safe mode, the possibility of a Master/ Slave IDE conflict is ruled out I guess. I just can’t put a finger on the problem. :doh:

Please Help!! :bow:

Regards,

Sameer :bigsmile:

I think the problem is cable select try setting it to Slave and try that again.

Take that CD-ROM out and put the 20A1P as Master using an 80-conductor IDE cable. Otherwise, the CD-ROM and 40-conductor IDE cable is limiting the 20A1P’s potential.

Before I open up the chassis and start fiddling around with the jumpers and the cables. Wouldn’t it affect the DVD in safe mode too , if there was a problem with the IDE or the Master/Slave. As I mentioned earlier, it works just fine in safe mode.

Well first off you shouldn’t even be using 40 pin anymore - it should be only 80 pin and one should be set Master and one set Slave. I think your CS and cable is probably the cause of the reading and accessing problem.

As some people said, most 40-conductor cables do not support Cable Select; the jumpers on the drives must be manually set to Master or Slave if such a cable is used.

The newer 80-conductor cables, on the other hand, do support Cable Select. In addition, they are required for operation above Ultra DMA/33 speeds.

As I said earlier , I don’t think it’s a problem with the cables or Master/Slave because if that were the case , it wouldnt even work in SAFE MODE. Anyway , I swapped the cables and now my DVD Writer is Master and My LG is slave. But the problem still persists.

Helpppppppp

Hey guys ,

I managed to fix the problem myself.

Just for the record , the problem was with with my IDE driver settings. It was set to take DMA if Available instead of a PIO only.

Steps to resolve the problem

  1. Went into Device Manage and expanded the IDE ATA\ATAPI hive.

  2. I was confused at this point because I didn’t know which IDE channel were my drives on … Primary or Secondary. So I clicked the properties of the Seconday IDE Channel and then clicked the “Details” tab. Under details , I selected “Bus Relations” from the pull down menu. Both my CD ROM and DVD ROM were displayed. DVD ROM was displayed first so i figured that was indicating MASTER (since my DVD is set as master).

  3. After confirming using step 2 that I had my drives on Secondary IDE channel , I clicked on the Advanced Settings Tab of the Secondary IDE channel properties.

  4. Here I changed the TRANSFER MODE for device 0 (MY DVD ROM) from “DMA if available” TO “PIO only”

That fixed the problem…

Thank’s for all your help and efforts.

Cheers!

What? You have 3 drives now? CD-ROM, DVD-ROM, and 20A1P? If you mean your 20A1P as the “DVD-ROM,” and want to use it in PIO mode, good luck, as you’ll never get burning done right as the buffer will fluctuate erratically. Advice have been given and if you’re still adamant about cables and master/slave settings as non-issues, then by all means, use PIO mode. Windows Safe mode doesn’t load many drivers, only minimal ones to have the O/S run to debug any problems caused by bad settings or installs. Just because you see the proper settings in Safe mode doesn’t mean it should work in Normal mode.

Well what else can I do ? I’ve performed a clean boot of XP. I’ve even removed ghost drivers from safe mode. They keep coming back. Why ? I have no idea.

There is something queer though … Under my DVD/CD Rom’s. I have 2 entries of the following item.

LU1303N ZOX279X Scsi CD Rom device.

What’s weird is that I don’t have 3 or 4 Dvd/Cd Rom’s. I have only 2 which are listed. I don’t know how or why the above should be listed and twice. Tried removing it but it just comes back…

PIO must have something to do with Processor Interrupting mode right? Which means it doesn’t use the DMA controller. Does this mean that while in safe mode, the DVD by default works in PIO mode? I don’t think there are different drivers for the IDE controller that are loaded in safe mode. With earlier version of windows 16bit drivers were loaded but I guess that changed with XP safe mode. Then how and why should it still be a Master/Slave or IDE issue? As far as the 40 pin / 80 pin IDE goes, I have always had this IDE cable ever since I bought the DVD drive. It worked just fine. Then I gave it to get repaired and I got this 20A1P as replacement.

If it was a master-slave issue or a cable issue, don’t you think it would affect the PIO mode as well ? I apologize if I may sound like I’m challenging your knowledge or arguing. It’s just that I’m curious to know WHY!!

Thank’s & Helppppppppp :bow:

Sameer :wink:

You must have a virtual drive/emulation software installed (Alcohol, Daemon Tools, Virtual CloneDrive to name but a few). That’ll be what the extra “drive” is.

Oh yeah I do :smiley: ,

I got Daemon Tools…

That shouldn’t be the cause of the problem then right ?

Hey , I just checked the System Logs and this is the error logged there

The driver detected a controller error on \Device\CdRom0.

For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

Hi ,

I changed the IDE cable to an 80 pin and this seems to have solved the problem. My drive is now on DMA if Available mode, and is reading dvd’s without a problem in the XP normal mode too. :iagree:

This is what I learnt

  1. Safe mode uses IPO by default and that is why I was being able to read the disc in safe mode.

  2. DVD writers should not be connected to a 40 pin IDE cable as that limits the speed.

  3. There was no problem with the Master/Slave settings.

Thank you all for your help, and I apologize if I sounded rude while reasoning. I was just curious.

Thank’s again. :bow:

Sameer :smiley: